Catalog Search is stuck on "Reindex Required"

i have been unable to fix this problem …i tried to follow ur recent video in indexing ut didnt work…quick search cant find my product when ever u search …
pls help

Indexing usually takes place after doing a certain action on the backend. Sometimes, you will get a couple of Indexers that get “stuck”.

You can force an index anytime by using the indexer command described in this Tutorial (How to reindex Magento 2 manually).

In your case, I’d run the following command as the magento user from within the Magento root directory:

bin/magento indexer:reindex catalogsearch_fulltext

This will set your Catalog Search value to “Ready”

Update on Schedule Indexing
Personally, I have all of Indexers set to Update on Schedule instead. This means that Indexers only run when I want them to run. And I can set them to run via a cron task. This is the preferred method of Indexing when you’re working on Magento sites with 1,000s of SKUs when potentially more than one admin is editing the backend at the same time.

After setting all Indexers to “Update on Schedule”, you’d open your crontab as the magento user with the command:

crontab -e

And then paste this beneath your existing Magento cron tasks

* 2 * * * /usr/bin/php /var/www/vhosts/ indexer:reindex

Example of crontab after adding the line

i this the following error message…

Catalog Search indexer process unknown error:
SQLSTATE[HY000]: General error: 1813 Tablespace for table '`fxdon1_mage134`.`mgs8_catalogsearch_fulltext_scope1`' exists. Please DISCARD the tablespace before IMPORT., query was: CREATE TABLE IF NOT EXISTS `mgs8_catalogsearch_fulltext_scope1` (
  `entity_id` int UNSIGNED NOT NULL COMMENT 'Entity ID' ,
  `attribute_id` int UNSIGNED NOT NULL COMMENT 'Attribute_id' ,
  `data_index` longtext NULL COMMENT 'Data index' ,
  PRIMARY KEY  (`entity_id`, `attribute_id`),
) COMMENT='mgs8_catalogsearch_fulltext_scope1' ENGINE=INNODB charset=utf8 COLLATE=utf8_general_ci

I’ve never had this issue before. But there does seem to be a solution to this problem that can be found here. You’ll have to adapt accordingly. Make sure you backup your database before making any changes.

At least that explains why Catalog Search wasn’t Indexing on Save.

as u said i did a backup and reinstall my magento 2.3 and it fixed the error thanks so much…u will be rewarded someday