How to setup SMTP and configure email accounts? M2

#1

Hello everyone!

Straight to the point. I have several email accounts with ZOHO mail, like sale@mydomain.com , suppourt@mydomain.com , info@mydomain.com … etc.

I need to add those accounts to the corresponding Store Email Addresses and have them working fine.

I have checked many smtp extensions but they all allow you to configure only one account and use it though out the whole over the place, so let say if I used the sale@… account to configure the smtp extension, all of my communication with the client are gonna be coming from sales@… even for technical support which is not convenient in my opinion.

Is there any other way to properly configure the emails.

my current setup is:
Ubuntu 16.04 on digitalocean
magento 2.3.1

#2

Hi @Ali_Alnemer and welcome.

I’m not familiar with Zoho, but if you have 3 linked email accounts then I would imagine that they all share the same SMTP credentials. That’s how it normally works. You might want to clarify that with Zoho.

Anyway, for SMTP extensions you should checkout this post: Magento 2.3 SMTP Recommendations

#3

I think you can configure different emails and associate them with different use-cases. It’s done outside the SMTP config … I’ll check and confirm next time I’m logged in.

Also, keep in mind Zoho quietly blocked SMTP last year for free accounts. Might not affect you if you’re on their paid plans but keep in mind if you’re on free tier and having problems using their SMTP settings.

Update:

  1. Set your email addresses under Stores >> Configuration >> General >> Store Email Addresses.
  2. Select your preferred email for different scenarios. e.g. for sales go to Stores >> Configuration >> General >> Sales >> Sales Emails and select the appropriate address.

The link @digitalstartup provided gives an overview of how to setup a connection to an SMTP service. Magento will try to use the configured SMTP service for whichever email addresses you specify for each scenario … if that makes sense :slightly_smiling_face:

2 Likes
#4

This post was flagged by the community and is temporarily hidden.