Not able to backup my files due to permission issues

I’m in web wizard and i cant seem to get it to work. This is the error im getting

As per the error:

Not enough permissions to read files for backup

You’ll want to diagnose and repair your permissions. This guide will walk you through everything and more: How to diagnose and fix Ownerships and Permission issues

Im getting this in my cmd

I don’t think you’re running chmod as the correct user. Please, go over that post I shared.

I followed the steps its still not backing up the files.

Copy and paste the output from the following command. Run the command from within the Magento root directory:

ls -la var/backups

Thats what i got from running that command.


ls -la app/etc/

So, Magento can’t backup your files because there are 1 or more files that don’t allow Magento to read them. It’s simply a case of finding the files. Obviously, Web Setup Wizard doesn’t tell you which folders/files are the culprit.

The easy Linux trick to locate folders/files that the “Magento” user can’t access/read is by running a Find command from the Command Line Interface. Any folders or files it can’t read will be output on the screen. Run the following as the Magento user from with the Magento root directory:

grep -Rl 'thisisatestsearch' .

It’ll either come back empty or display a list of files it can’t read. Whatever files are listed, inspect them closer for Owner/Group/Permission issues. I’ll check back tomorrow with how you got on. Please, keep us posted.

Thanks, and i will. I ran the command and it didn’t return anything. Where do i go to see the Owner/Group/Permission issues?

Sorry for delay. How did you get on?