Bin/magento cron:install error

There are no commands defined in the “cron” namespace.

Did you mean this?

Not had this before on Ubuntu 16.04, not sure what to do.


Hi @lee737 and welcome.

Please, can you add some context to your issue/question. The more information you add, the quicker and more detailed the responses you’ll receive.

Hi Craig, should have closed this yesterday. I realised I hadnt gone to the browser for the install of magento :blush:

But its all good now and https and cert is set up.

Cant wait to get stuck into the other magento tutorials you have done and thanks for your hard work.

On your tut perhaps add at the end to switch cache back on as I got stuck with that even after reboot and took me a while to figure out what was happening. I found the php bin/magento cache:enable command which fixed that.

Thanks for getting back to me, Lee

1 Like

I encountered this problem also. I google it, but no the right answer, So i don’t know how to solve this problem.

I install the magento2 by the tutorial at the website: howtoforge, at the step :
./bin/magento cron:install , via the S-S-H, xshell.
so the problem comes out.

does someone can help us?

hello, can you give me detail solution. I encounter this problem and I google the problem, but still did not solve, so could you give me the detail command. I use the SSH, the Xshell. I do not know the detail command to solve this problem, I used the command ```
/bin/magento cron:install

could you give me more detail command?

facing “There are no commands defined in the “cron” namespace”. could you please tell me the solution?