Changing logo in magento 2.3.0

Hey guys, having an issue changing the standard luma logo, tried matching dimensions to no avail, just get the following error

A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later.

any ideas?

This has been a reoccurring issue for a number of reasons. Sometimes it’s been because of a bug in an update - But I think that’s fixed in v2.3. You might want to try these solutions instead:

1. User Role bug

  • Create a new Magento Admin and try and make changes whilst logged in as that user

2. Permission/Owner Issue/Oversight

  • Run the following command (as root or magento) to ensure that all folder permissions are correct

find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + && find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + && chown -R :www-data . && chmod u+x bin/magento

3. Old Magento bug
This was the original workaround to an old bug. I don’t ever recommend editing any files in the app/vendor folder. But thought I’d mention anyway.

  • Update lines number 57 & 154 from fileUploader to imageUploader in vendor/magento/module-theme/view/adminhtml/ui_component/design_config_form.xml

Hey again… Oh my what a nightmare this is becoming… I was expecting a much more reliable setup than presta, starting to wonder. Anyways… I am now resorting to a 7th attempt at a fresh rebuild and install after trying a snapshot rollback pre-demo content install to be greeted by a blank screen and nothing.

The 6th attempt was throwing errors like “unable to locate package php7.2 - soap”

think i am about to lose what hair i have left haha

Welcome to the first mile of the marathon. Magento isn’t for everyone, but once you’re over the peak of the giant learning curve everything starts to “click”. Bare in mind that Magento is aimed at Enterprise level businesses to tailor the software for their needs. So with all of this flexibility and power come the headaches.

For anyone simply wanting to skip the installation part and jump straight into the setup, I always recommend Nexcess SIP-100 Package. They specialise in Magento Web Servers and that package is super-competitive when compared to other Magento web server specialists. I used to have 3 servers with them before moving everything to unmanaged servers (For me the freedom to do what I want on the server is far greater than the support I probably won’t ever need).

If you’d prefer to stick to the more nerdy option of building Magento 2 from scratch, I’d recommend taking a break and picking it back up tomorrow. I refer to my own instructions when rebuilding servers (too many steps to remember) and I can speedrun a build in around 25-30 minutes these days.

Most of the post/comments I get about installation issues normally come down to typos or missed steps, which are more likely to happen when you’re fatigued and frustrated. Believe, I’ve been there - There weren’t any good guides when I started using Magento, so I had to do it over-and-over again during a course of weeks so I could finally write an easy to follow guide.

Good luck :+1:

Thanks Craig for the support, Think a rest is needed… Just tried a 18.04 install and now credentials arent working in phpmyadmin to setup the db… dont think that nexcess will be any good for us with the 100 user limit, and after that the cost rises dramatically

Gotcha. I tried both 16.04 and 18.04 when I wrote the guide. 16.04 wasn’t as complicated so I pushed ahead with that.

But later on I documented the extra steps here if you want to keep trying on that version. 18.04 uses more up-to-date repositories with extra layers of security. You’ll probably see why I opted to stick with 16.04 for the guides. I don’t think you’ll run into anything else, but I don’t run any of my servers on 18.04 so I wouldn’t really know.

Anyway, signing off for the day. Please, keep us posted with your progress over the week.

1 Like

Hi Craig!

I’ve tried the suggested solutions to load the logo and favicon and to the present without success. The error continues “A technical problem with the server created an error. Try again to continue what you were doing. If the problem persists, try again later.”

If you have any suggestions for the problem, thank you. Otherwise I will wait for the update to 2.3.1.

So, I’ve been so busy recently that I’ve not had a chance to actually “use” Magento 2.3 since I did the video last year. My sandbox server still has a clean install that’s not been touched.

I’ve just gone to upload a Logo and have the exact error that you’ve shown. At first, I assumed that the issue was just because the appropriate folders didn’t exist. It turns out, this isn’t the case.

It does in fact look like a Bug in Magento 2.3 (Ref this article). I’ve tested the “workaround” and it does fix the issue. Although, I wouldn’t recommend the method as it means editing core code. If you’re testing/playing then there’s technically no harm, especially as this file will be overwritten when you next patch Magento anyway.

I’m just shocked that they’ve left this bug sit here for so long. I think that’s nearly 2 months since release. Another reason why I don’t upgrade my Production environments to major versions until the patches come out.

Hi Craig!

I used the article you suggested and it worked fine for uploading the logo and favicon photo.

Thanks for the help and the excellent magento help channel.

1 Like