Composer install isn't complete

Dedicated Server / Install Magento myself / Centos 7.9, Php 7.4, Mysql 8, Magento 2.4.1

Hi, Could anyone help this?

When I try to install M 2.4.1 with composer

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition=2.4.1

I got this error and composer install wasn’t complete

  • Installing pdepend/pdepend (2.7.1): Loading from cache
  • Installing phpmd/phpmd (2.9.1): Loading from cache
  • Installing phpstan/phpstan (0.12.23): Loading from cache
    laminas/laminas-validator suggests installing laminas/laminas-i18n-resources (Tr anslations of validator messages)
    laminas/laminas-http suggests installing paragonie/certainty (For automated mana gement of cacert.pem)
    laminas/laminas-servicemanager suggests installing ocramius/proxy-manager (Proxy Manager 0.5.* to handle lazy initialization of services)
    laminas/laminas-filter suggests installing psr/http-factory-implementation (psr/ http-factory-implementation, for creating file upload instances when consuming P SR-7 in file upload filters)
    laminas/laminas-form suggests installing laminas/laminas-recaptcha (in order to use the ReCaptcha form element)
    laminas/laminas-mvc suggests installing laminas/laminas-authentication (Laminas\ Authentication component for Identity plugin)
    laminas/laminas-mvc suggests installing laminas/laminas-servicemanager-di (^1.0. 1, if using laminas-servicemanager v3 and requiring the laminas-di integration)
    laminas/laminas-math suggests installing ext-gmp (If using the gmp functionality )
    laminas/laminas-math suggests installing ircmaxell/random-lib (Fallback random b yte generator for Laminas\Math\Rand if Mcrypt extensions is unavailable)
    laminas/laminas-crypt suggests installing ext-mcrypt (Required for most features of Laminas\Crypt)
    monolog/monolog suggests installing graylog2/gelf-php (Allow sending log message s to a GrayLog2 server)
    monolog/monolog suggests installing sentry/sentry (Allow sending log messages to a Sentry server)
    monolog/monolog suggests installing doctrine/couchdb (Allow sending log messages to a CouchDB server)
    monolog/monolog suggests installing ruflin/elastica (Allow sending log messages to an Elastic Search server)
    monolog/monolog suggests installing ext-amqp (Allow sending log messages to an A MQP server (1.0+ required))
    monolog/monolog suggests installing ext-mongo (Allow sending log messages to a M ongoDB server)
    monolog/monolog suggests installing mongodb/mongodb (Allow sending log messages to a MongoDB server via PHP Driver)
    monolog/monolog suggests installing rollbar/rollbar (Allow sending log messages to Rollbar)
    monolog/monolog suggests installing php-console/php-console (Allow sending log m essages to Google Chrome)
    symfony/console suggests installing symfony/lock
    guzzlehttp/psr7 suggests installing laminas/laminas-httphandlerrunner (Emit PSR- 7 responses)
    paragonie/random_compat suggests installing ext-libsodium (Provides a modern cry pto API that can be used to generate random bytes.)
    ramsey/uuid suggests installing ircmaxell/random-lib (Provides RandomLib for use with the RandomLibAdapter)
    ramsey/uuid suggests installing ext-libsodium (Provides the PECL libsodium exten sion for use with the SodiumRandomGenerator)
    ramsey/uuid suggests installing ext-uuid (Provides the PECL UUID extension for u se with the PeclUuidTimeGenerator and PeclUuidRandomGenerator)
    ramsey/uuid suggests installing moontoast/math (Provides support for converting UUID to 128-bit integer (in string form).)
    ramsey/uuid suggests installing ramsey/uuid-doctrine (Allows the use of Ramsey\U uid\Uuid as Doctrine field type.)
    ramsey/uuid suggests installing ramsey/uuid-console (A console application for g enerating UUIDs with ramsey/uuid)
    magento/framework suggests installing ext-imagick (Use Image Magick >=3.0.0 as a n optional alternative image processing library)
    laminas/laminas-session suggests installing laminas/laminas-cache (Laminas\Cache component)
    laminas/laminas-session suggests installing mongodb/mongodb (If you want to use the MongoDB session save handler)
    laminas/laminas-captcha suggests installing laminas/laminas-i18n-resources (Tran slations of captcha messages)
    laminas/laminas-captcha suggests installing laminas/laminas-recaptcha (Laminas\R eCaptcha component)
    magento/module-widget suggests installing magento/module-widget-sample-data (Sam ple Data version: 100.4.)
    magento/module-asynchronous-operations suggests installing magento/module-loggin g (
    )
    magento/module-theme suggests installing magento/module-theme-sample-data (Sampl e Data version: 100.4.)
    magento/module-wishlist suggests installing magento/module-wishlist-sample-data (Sample Data version: 100.4.
    )
    magento/module-tax suggests installing magento/module-tax-sample-data (Sample Da ta version: 100.4.)
    magento/module-sales-rule suggests installing magento/module-sales-rule-sample-d ata (Sample Data version: 100.4.
    )
    magento/module-sales suggests installing magento/module-sales-sample-data (Sampl e Data version: 100.4.)
    magento/module-catalog suggests installing magento/module-catalog-sample-data (S ample Data version: 100.4.
    )
    magento/module-customer suggests installing magento/module-customer-sample-data (Sample Data version: 100.4.)
    magento/module-cms suggests installing magento/module-cms-sample-data (Sample Da ta version: 100.4.
    )
    magento/module-downloadable suggests installing magento/module-downloadable-samp le-data (Sample Data version: 100.4.)
    magento/module-msrp suggests installing magento/module-msrp-sample-data (Sample Data version: 100.4.
    )
    magento/module-catalog-rule suggests installing magento/module-catalog-rule-samp le-data (Sample Data version: 100.4.)
    magento/module-review suggests installing magento/module-review-sample-data (Sam ple Data version: 100.4.
    )
    magento/module-bundle suggests installing magento/module-bundle-sample-data (Sam ple Data version: 100.4.)
    vertex/module-tax suggests installing magento/module-gift-wrapping (Vertex Tax L inks for Magento 2 also supports Magento’s Gift Wrapping module)
    vertex/module-tax suggests installing magento/module-gift-card-account (Vertex T ax Links for Magento 2 also supports Magento’s Gift Card Account module)
    vertex/module-tax suggests installing magento/module-reward (Vertex Tax Links fo r Magento 2 also supports Magento’s Reward module)
    magento/module-inventory-visual-merchandiser suggests installing magento/module- visual-merchandiser (
    )
    magento/module-inventory-requisition-list suggests installing magento/module-req uisition-list ()
    magento/module-grouped-product suggests installing magento/module-grouped-produc t-sample-data (Sample Data version: 100.4.
    )
    magento/module-configurable-product suggests installing magento/module-configura ble-sample-data (Sample Data version: 100.4.)
    magento/module-configurable-product suggests installing magento/module-product-l inks-sample-data (Sample Data version: 100.4.
    )
    magento/module-inventory-advanced-checkout suggests installing magento/module-ad vanced-checkout ()
    phpseclib/phpseclib suggests installing ext-libsodium (SSH2/SFTP can make use of some algorithms provided by the libsodium-php extension.)
    phpseclib/phpseclib suggests installing ext-mcrypt (Install the Mcrypt extension in order to speed up a few other cryptographic operations.)
    phpseclib/phpseclib suggests installing ext-gmp (Install the GMP (GNU Multiple P recision) extension in order to speed up arbitrary precision integer arithmetic operations.)
    symfony/property-info suggests installing psr/cache-implementation (To cache res ults)
    symfony/property-info suggests installing symfony/doctrine-bridge (To use Doctri ne metadata)
    symfony/property-info suggests installing symfony/serializer (To use Serializer metadata)
    symfony/property-access suggests installing psr/cache-implementation (To cache a ccess methods.)
    bacon/bacon-qr-code suggests installing ext-imagick (to generate QR code images)
    endroid/qr-code suggests installing roave/security-advisories (Avoids installati on of package versions with vulnerabilities)
    endroid/qr-code suggests installing setasign/fpdf (Required to use the FPDF writ er.)
    endroid/qr-code suggests installing symfony/security-checker (Checks your compos er.lock for vulnerabilities)
    amzn/amazon-pay-module suggests installing magento/module-scalable-checkout (
    )
    amzn/amazon-pay-module suggests installing magento/module-scalable-oms ()
    magento/module-swatches suggests installing magento/module-swatches-sample-data (Sample Data version: 100.4.
    )
    magento/module-sample-data suggests installing magento/sample-data-media (Sample Data version: 100.4.)
    magento/module-offline-shipping suggests installing magento/module-offline-shipp ing-sample-data (Sample Data version: 100.4.
    )
    symfony/event-dispatcher-contracts suggests installing psr/event-dispatcher
    symfony/event-dispatcher suggests installing symfony/http-kernel
    paragonie/sodium_compat suggests installing ext-libsodium (PHP < 7.0: Better per formance, password hashing (Argon2i), secure memory management (memzero), and be tter security.)
    paragonie/sodium_compat suggests installing ext-sodium (PHP >= 7.0: Better perfo rmance, password hashing (Argon2i), secure memory management (memzero), and bett er security.)
    laminas/laminas-json suggests installing laminas/laminas-xml (To support Laminas \Json\Json::fromXml() usage)
    laminas/laminas-view suggests installing laminas/laminas-authentication (Laminas \Authentication component)
    laminas/laminas-view suggests installing laminas/laminas-mvc-plugin-flashmesseng er (laminas-mvc-plugin-flashmessenger component, if you want to use the FlashMes senger view helper with laminas-mvc versions 3 and up)
    laminas/laminas-view suggests installing laminas/laminas-navigation (Laminas\Nav igation component)
    laminas/laminas-view suggests installing laminas/laminas-paginator (Laminas\Pagi nator component)
    laminas/laminas-view suggests installing laminas/laminas-permissions-acl (Lamina s\Permissions\Acl component)
    laminas/laminas-log suggests installing ext-mongo (mongo extension to use Mongo writer)
    laminas/laminas-log suggests installing ext-mongodb (mongodb extension to use Mo ngoDB writer)
    laminas/laminas-i18n suggests installing laminas/laminas-cache (Laminas\Cache co mponent)
    laminas/laminas-i18n suggests installing laminas/laminas-i18n-resources (Transla tion resources)
    laminas/laminas-feed suggests installing laminas/laminas-cache (Laminas\Cache co mponent, for optionally caching feeds between requests)
    jms/serializer suggests installing doctrine/collections (Required if you like to use doctrine collection types as ArrayCollection.)
    phpunit/php-invoker suggests installing ext-pcntl ()
    sebastian/global-state suggests installing ext-uopz (
    )
    phpunit/php-code-coverage suggests installing ext-pcov ()
    phpunit/php-code-coverage suggests installing ext-xdebug (
    )
    phpunit/phpunit suggests installing ext-xdebug (*)
    friendsofphp/php-cs-fixer suggests installing php-cs-fixer/phpunit-constraint-is identicalstring (For IsIdenticalString constraint.)
    friendsofphp/php-cs-fixer suggests installing php-cs-fixer/phpunit-constraint-xm lmatchesxsd (For XmlMatchesXsd constraint.)
    lusitanian/oauth suggests installing predis/predis (Allows using the Redis stora ge backend.)
    php-webdriver/webdriver suggests installing ext-SimpleXML (For Firefox profile c reation)
    hoa/console suggests installing hoa/dispatcher (To use the console kit.)
    hoa/console suggests installing hoa/router (To use the console kit.)
    hoa/console suggests installing ext-pcntl (To enable hoa://Event/Console/Window: resize.)
    league/flysystem suggests installing league/flysystem-eventable-filesystem (Allo ws you to use EventableFilesystem)
    league/flysystem suggests installing league/flysystem-rackspace (Allows you to u se Rackspace Cloud Files)
    league/flysystem suggests installing league/flysystem-azure (Allows you to use W indows Azure Blob storage)
    league/flysystem suggests installing league/flysystem-webdav (Allows you to use WebDAV storage)
    league/flysystem suggests installing league/flysystem-aws-s3-v2 (Allows you to u se S3 storage with AWS SDK v2)
    league/flysystem suggests installing league/flysystem-aws-s3-v3 (Allows you to u se S3 storage with AWS SDK v3)
    league/flysystem suggests installing spatie/flysystem-dropbox (Allows you to use Dropbox storage)
    league/flysystem suggests installing srmklive/flysystem-dropbox-v2 (Allows you t o use Dropbox storage for PHP 5 applications)
    league/flysystem suggests installing league/flysystem-cached-adapter (Flysystem adapter decorator for metadata caching)
    league/flysystem suggests installing league/flysystem-sftp (Allows you to use SF TP server storage via phpseclib)
    league/flysystem suggests installing league/flysystem-ziparchive (Allows you to use ZipArchive adapter)
    doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required to use le gacy MongoDB driver)
    cache/cache suggests installing ext-apc (APC extension is required to use the AP C Adapter)
    cache/cache suggests installing ext-apcu (APCu extension is required to use the APCu Adapter)
    cache/cache suggests installing ext-memcache (Memcache extension is required to use the Memcache Adapter)
    cache/cache suggests installing ext-memcached (Memcached extension is required t o use the Memcached Adapter)
    cache/cache suggests installing ext-redis (Redis extension is required to use th e Redis adapter)
    cache/cache suggests installing ext-mongodb (Mongodb extension required to use t he Mongodb adapter)
    cache/cache suggests installing mongodb/mongodb (Mongodb lib required to use the Mongodb adapter)
    codeception/codeception suggests installing codeception/specify (BDD-style code blocks)
    codeception/codeception suggests installing codeception/verify (BDD-style assert ions)
    codeception/codeception suggests installing symfony/phpunit-bridge (For phpunit- bridge support)
    codeception/codeception suggests installing stecman/symfony-console-completion ( For BASH autocompletion)
    codeception/module-webdriver suggests installing codeception/phpbuiltinserver (S tart and stop PHP built-in web server for your tests)
    aws/aws-sdk-php suggests installing aws/aws-php-sns-message-validator (To valida te incoming SNS notifications)
    symfony/dependency-injection suggests installing symfony/expression-language (Fo r using expressions in service container configuration)
    symfony/dependency-injection suggests installing symfony/proxy-manager-bridge (G enerate service proxies to lazy load them)
    phpcompatibility/php-compatibility suggests installing roave/security-advisories (dev-master || Helps prevent installing dependencies with known security issues .)
    Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
    Package sebastian/finder-facade is abandoned, you should avoid using it. No repl acement was suggested.
    Package phpunit/php-token-stream is abandoned, you should avoid using it. No rep lacement was suggested.
    Writing lock file
    Generating autoload files
    88 packages you are using are looking for funding.
    Use the composer fund command to find out more!
    PHP CodeSniffer Config installed_paths set to …/…/magento/magento-coding-stand ard,…/…/phpcompatibility/php-compatibility

[magento_folder]# dir
project-community-edition

(I did ‘composer self-update 1.10.16’ too as the manual guide)

its complete. What directory did you install the magento in?

Also just go the webbrowser and load your url.

Yes. It’s complete. My misunderstanding…!
Please delete this post!