Composer Repository not found

Good Morning Craig,

Am a new user and trying to install Magento 2.3 on digitalocean with following link from your website: How to install Magento 2.3 and build a web server.

Everything went well as per the tutorial but when I come to installing composer am getting error.

composer create-project --repository-url= magento/project-community-edition .
Requested public / private key but then am getting error:

Installing magento/project-community-edition (2.3.3)
  - Installing magento/project-community-edition (2.3.3): Loading from cache
Created project in .
Loading composer repositories with package information
Updating dependencies (including require-dev)
  The "  381ea89c16329ef91b7a71796a207498eb.json" file could not be downloaded (HTTP/1.1 404 Not Found)

I checked everything and haven’t missed any step. Checked all the forms can’t find any answer. Destroyed and re-created droplet but still same error.

Am using Ubuntu 16.04.6 LTS x64.

Thanks in advance for you assistance on this.

Hi Craig,

Have bit progress on this! I’ve started again and this time everything west well probably I missed something before. I must say your tutorial is flawless!
Installed composer and magento without any glitch.

When I was doing web configuration I was thinking of my store and have changed some settings accordingly. On Web Configuration I have added and custom admin address also in Advanced Options > Used HTTPS for store front and admin.

Now am getting error " This site can’t be reached " when I use with www or with http://www. or https://www. I tried using IP address but no luck!

I just installed SSL certificate from DO but still same error.

Appreciate your assistance on this.

Thanks in advance.

Hi Craig,

Just watched tutorial “How to setup Let’s Encrypt Free SSL Certificate” and that has fixed everything.
My website is working fine with SSL. I shouldn’t have used https at the time of installation.

Thank you so very much! :slight_smile:

Hi @Hobb and welcome.

Whenever I see a 404 I always assume (wrongly or rightly) that it’s “their” end. Did you have any luck a second time around?

If not, you might want to try clearing the Composer Cache by running the following command:

composer clear-cache 

And then running the composer command again. Note that you’ll need to clear anything out of /var/www/html/ again otherwise Composer will refuse to run because the folder isn’t empty.