CSV File Upload | Fake Russian Customer Accounts


(David) #1

Hi Craig,

I have 2 issues I really need help with.

  1. Firstly, I’ve created a CSV file as per your instructions and have uploaded it successfully with no errors. The thing is, it does not show on the backend as uploaded or display on the front end. I did manage to add the products manually to test and it’s fine. But of course, I need to use the csv method since there are many products. Is this a reindexing issue?

  2. In the customer section, there is a whole load of fake Russian account details. Not sure how they got there.

Any help would be great as I have limited knowledge of this. This is a Magento 2.6 site

Thanks in advance.

David


Product import doesn't appear on backend
(Craig) #2

Hey David,

CSV
Reindexing wouldn’t make a difference if it’s not showing on the backend either. Unless something’s changed recently that I’m not aware of.

  • What type of products are you uploading? e.g. Simple, Configurable, etc…
  • I assume you’re getting no errors on import?
  • I would also suggest going to System > Import > Entity Type: Products > Download Sample File to see if you’re missing anything obvious with the CSV format.
  • I’ll happily take a look if you want to share. I only need to see the first couple of lines.

Russian Accounts
I’ve seen this before on another Magento project. I assume the site is accessible/live where bots can crawl it? Something to do with spamming, but I’m not sure what the end goal is. Enabling Google reCaptcha for Account Registration fixed this for me. It’s not going to be featured until Magento 2.3. However, you can install it early by following these instructions. I nearly did a video on how to install it, but never got round to it. Alternatively, check if your Magento theme already comes with reCapture in its settings before going through that process.

I hope this helps in some way. Let me know how you get on.

Regards,
Craig


(David) #3

Hi Craig,

Thanks a lot for your help so far. It’s been invaluable. I’ve probably made a hash of the csv file. Please do take a look at let me know. The products are simple and I am not getting any errors on import.

It would have been great to have short video to help with Google reCaptcha. I did follow your other video on reindexing, but could not get PuTTY to connect and so gave up in the end.

Thanks again.

David

https://drive.google.com/file/d/1WGkrdT1SyenItSarj-V7Lp5GtaGBIS4a/view?usp=sharing


(Craig) #4

I think your issue might be down to missing the product_websites Column. Try adding adding that column and setting the cell values to base for each line.

Example
try

As for your Putty issue, you might need to reach out to your web hosts. It’ll likely be some sort of whitelist issue.


(David) #5

Hello again,

Added the product_website but still nothing when I upload.

I’m also trying to sort out the PuTTy issue. Let me know if you have any more suggestions. A few of the indexes are invalid. I know you said this does not matter.


(Craig) #6

Access to the server via SSH (Putty) will be super-useful. Once you gain access to your server, you’ll want to try and run the following commands:

Be sure to run commands from Magento root directory as the file-owner. If you’re using Shared Hosting, then the file-owner will likely be who you log in as.

Manual Index
bin/magento indexer:reindex
I don’t think this will effect products showing on the backend, but I could be wrong.

Cron Setup
bin/magento cron:install
I’ve not tried this one, as I usually do it manually. But you can find more info here.


(Craig) #7

I was thinking about this last night. And I was wondering if it was worth Importing your CSV (with the additional of the product_websites column) and set the Import Behavior to Delete. Then once you’ve done that, re-upload the file with Import Behaviour set to Add/Update.

My theory behind it is to simply “start again” in case the original import messed something up. Although, I’m not sure how thorough the Delete option is for Importing. My hope is that it doesn’t leave any trace of the existing products.

Just an idea, in case you were looking for one. Good luck.


(Fred) #8

I have found myself having the same kind of issues while importing CSV sheets. I am using Excel to create my CSV import files and somehow, Excel doesn’t save the CSV format properly and will cause them to not import into magento without providing any errors.
My fix around this is to upload the CSV sheet into Google sheet and then download it as a CSV format before importing them into Magento.
Might work in your case too. Let me know if i am not detailed enough in my explanation.


(Craig) #9

Great tip, @Accessotronik.

Funny you should mention Excel… I was dealing with a CSV containing 1500 SKUs over the weekend in Excel. (I never normally use Excel for CSVs but I was being lazy). I saved/closed the file and it saved all the SKUs as scientific notations (e.g. 12345678901 saved as 1.23E+1). I had to redo the entire sheet :sob:


(Fred) #10

Cell formatting can be such a pain :disappointed:


(David) #11

Thank you all. Will try these options. The whole thing is such a pain. Spent a good few hours with the tech team that day trying to resolve the PuTTy not connecting issue. Still was not resolved. I did try to upload and then delete the CSV file when Craig first suggested it. However, when I tried this is was giving me another error message so I just gave up with it.

Will try it again soon, for now have lost patience with the whole build. Can’t seem to get much traction with it.