Curly brackets issue - stuck at 45:37


I’m stuck at 45:37 (How to install Magento 2.3 and build a web server)

If I copy or type or use alt+123 or alt+125 to get curly brackets {}, I get multicurly brackets.
If I just cut the command: find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w or find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws answer: "find: missing argument to ‘-exec’ "

chown -R :www-data .
chmod u+x bin/magento
last two will give operation not permitted

Any ideas, anybody?

Hi @Katrin_nirtaK and welcome.

The find command won’t work without the {}, hence the -exec error.

I don’t think I’ve ever seen a bracket like that before… Perhaps it has something to do with your PC/Keyboard configuration? I don’t even see anything on Google relating to this type of symbol.

If this is an issue you only get whilst interacting with a Unix OS via SSH then you might get a quicker response to this particular issue by asking here:

Please, do share the answer when you have it.

I had problems with this | also, but alt+124 worked for that. And if I think further - probably supercurlybracket is connected to my win10 language, which is not English. I tried “on screen keyboard” and also different languages. If the language restart won’t solve the issue, I’ll start using Ubuntu again.

Problem exits because I use digitalocean access console as terminal. And font won’t work for {}.

Digitalocean rejects my Powershell public key, the very same, what works fine for my other server

Gotcha. Thanks for sharing. I’ve never really bothered with the inbuilt consoles that are available with Server Hosts as they all seem a bit temperamental. If you’re on Windows then I recommend Putty (64-bit).