Error after installing language pack: Unable to serialize value

#1

Hi Craig,

Its me here again, now I get you on something I think many more than just me might be facing. I want to install the language pack (in my case Swedish sv_SE).
I have followed each and every step in this guide:

And in Putty everything works fine, I mean, I dont get any errors. But when I am going to active the Swedish language pack from Magento 2 admin panel, Stores > Configuration > General > Locale Options and set Sweden(Swedish) my frontend store turns ut:

1 exception(s):
Exception #0 (InvalidArgumentException): Unable to serialize value.

Exception #0 (InvalidArgumentException): Unable to serialize value.
#0 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Translate.php(514): Magento\Framework\Serialize\Serializer\Json->serialize(Array)
#1 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Translate.php(223): Magento\Framework\Translate->_saveCache()
#2 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Area.php(245): Magento\Framework\Translate->loadData('frontend', false)
#3 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Area.php(216): Magento\Framework\App\Area->_initTranslate()
#4 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Area.php(143): Magento\Framework\App\Area->_loadPart('translate')
#5 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/DesignLoader.php(55): Magento\Framework\App\Area->load('translate')
#6 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Action/Plugin/Design.php(48): Magento\Framework\View\DesignLoader->load()
#7 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(121): Magento\Framework\App\Action\Plugin\Design->beforeDispatch(Object(CleverSoft\CleverBuilder\Controller\Page\Index\Interceptor), Object(Magento\Framework\App\Request\Http))
#8 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): CleverSoft\CleverBuilder\Controller\Page\Index\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#9 /kunder/wpspku_3014/magent_5277/public/generated/code/CleverSoft/CleverBuilder/Controller/Page/Index/Interceptor.php(39): CleverSoft\CleverBuilder\Controller\Page\Index\Interceptor->___callPlugins('dispatch', Array, Array)
#10 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/FrontController.php(159): CleverSoft\CleverBuilder\Controller\Page\Index\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#11 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/FrontController.php(99): Magento\Framework\App\FrontController->processRequest(Object(Magento\Framework\App\Request\Http), Object(CleverSoft\CleverBuilder\Controller\Page\Index\Interceptor))
#12 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\App\FrontController->dispatch(Object(Magento\Framework\App\Request\Http))
#13 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\App\FrontController\Interceptor->___callParent('dispatch', Array)
#14 /kunder/wpspku_3014/magent_5277/public/vendor/magento/module-store/App/FrontController/Plugin/RequestPreprocessor.php(94): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#15 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(135): Magento\Store\App\FrontController\Plugin\RequestPreprocessor->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#16 /kunder/wpspku_3014/magent_5277/public/vendor/magento/module-page-cache/Model/App/FrontController/BuiltinPlugin.php(73): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#17 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(135): Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#18 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#19 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, NULL)
#20 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#21 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/App/Http/Interceptor.php(24): Magento\Framework\App\Http->launch()
#22 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http\Interceptor->launch()
#23 /kunder/wpspku_3014/magent_5277/public/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))
#24 {main}

Admin is still working fine. When I change Locale back to US again the frontend works again. Its maybe related to my topic Configure Default Store View
My solution over there was since the theme already had 2 store views installed (English and Swedish) and English was the default language that you say at the first time entering the store. I just changed the “name/titel/Text/tag” of English to Swedish and Swedish to English. And Viola! Then “Swedish” was the first language to see when entering the URL.

Maybe they are related, maybe not. Please help me with this “Unable to serialize value.”

Ps. If there is any easier way to manually translate your site to Swedish, please let me know.

Thanks

0 Likes

#2

Funny enough, I made a note the other day to do a video on Language Packs. At the moment, I’ve got just over 50 videos in my notepad :confused:

Admittedly, the only Language Pack I ever installed was en_GB but that wasn’t through Mageplaza.

If you can hold off, I’ll try and run through the Mageplaza instructions tonight and see if I get the same issue.

Having simple just glanced at the instructions, there are 2 things you might want to try in the meantime:

  1. Recompile (Only if you’re in Production Mode):
bin/magento setup:di:compile
  1. Include en_US when deploying static content:
bin/magento setup:static-content:deploy en_US sv_SE -f
  1. Flush your Redis Session Storage (Only if you’re using Redis)
redis-cli flushall

Therefore, the steps would be:

Install Swedish pack :

composer require mageplaza/magento-2-swedish-language-pack:dev-master
bin/magento setup:di:compile
bin/magento setup:static-content:deploy en_US sv_SE -f
bin/magento indexer:reindex
bin/magento cache:clean
bin/magento cache:flush
redis-cli flushall

Update Swedish pack :

composer update mageplaza/magento-2-swedish-language-pack:dev-master
bin/magento setup:di:compile
bin/magento setup:static-content:deploy en_US sv_SE -f
bin/magento indexer:reindex
bin/magento cache:clean
bin/magento cache:flush
redis-cli flushall

But that’s just a guess until I look properly.

EDIT: added -f at the end of the static-content command
EDIT 2: added redis-cli flushall

0 Likes

#3

Hi Craig, I’ll try and I get back to you. Stay close :wave:

0 Likes

#4

Hi Craig,

At the line

-bash-4.2$ magento setup:static-content:deploy en_US sv_SE -f

I faced this issue:

PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to al                                                                             locate 20480 bytes) in /kunder/wpspku_3014/magent_5277/public/vendor/oyejorge/le                                                                             ss.php/lib/Less/Tree/Selector.php on line 125
Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocat                                                                             e 20480 bytes) in /kunder/wpspku_3014/magent_5277/public/vendor/oyejorge/less.ph                                                                             p/lib/Less/Tree/Selector.php on line 125
Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-error 

And my server company says:

The memory limit is not reached if you run code that does not require over 1 GB of PHP memory. It’s a lot of memory, in fact, so it’s our maximum limit.

Any advice of other ways to do this?

0 Likes

#5

That’s an incredibly disappointing response from a company that hosts Magento 2 sites. Especially when the Official Magento Documentation recommends a minimum of 2G for PHP to run.

Magento 2 has differing PHP memory requirements, based on how your system is deployed. In general, if you are setting up a single server store and plan on using the web setup wizard, we recommend configuring PHP memory for 2G.

So, yes you’re getting errors because the commands are “crashing” due to lack of memory. I’m surprised that you’ve not run into this issue sooner.

If you’re server doesn’t have enough memory allocated for PHP, then you’ll continue to intermittently run into this issue - Especially after your store goes live because it will be under heavier strain.

Now, let’s assume for a moment that your web server package does have a 2GB available, but PHP has a limit set. Then you might be able to increase your PHP memory_limit by editing the .htaccess file. Just refer to the end of How to install Magento 2.3 and build a web server (Update memory_limit). That might give you the joice you need to run everything without crashing.

0 Likes

#6

Thanks for clear this issue out into smaller pieces.
The server company responses this:
This is also about performance. One or more features that require 1 GB of memory will take a long time to run. It provides a slow site and fewer visitors / purchases. You probably don’t want it.

So what I read here is that the moment you install any language pack, the site gets slow? Even if I had a server company having 2 gig PHP limit?
Then my second question is, how does sites that are running language pack managing the site speed?

0 Likes

#7

That doesn’t make any sense to me. Installing a language pack would have no discernible difference in performance.

  • Translatable text gets compiled before anyone visits your website.
  • Translatable text is not translated “on-the-fly”, therefore there is no additional processing power required.

That’s the whole point of Compilation and Caching.

Either way, it doesn’t matter what my opinion is. I’m pretty sure that if the creators of Magento recommend 2G, then that’s probably for a reason.

0 Likes

#8

Thank you for clarifying this, I will talk with them again.
But if they cannot manage this on server level, can you please run through this tonight and see if you can find another way around that doesnt need this memory.
If not, is the only solution to change server hosting company then? :hushed:

0 Likes

#9

I can tell you now that there isn’t a workaround for low memory specifications. If you don’t have the memory, then you simply don’t have the memory. The question you have to ask yourself is: Could you afford for this to happen 6 months from now during the middle of a trading day? You should really consider upgrading your current package or researching other providers that actually “specialise” in Magento 2 (Note: Many claim they do, but don’t).

0 Likes

#10

Hi Craig,
You are completely right. I understand we are not going to talk pros and cons about web hosts here, but this one is "on-the-rise in Scandinavia and says they are only specialists on Magento. They have fixed the installation for me, only support Magento 2.3 and has PHP 7.2. So far so “professional” good. But in this case, the memory limit for PHP is 1 gig in their arms…so I get your point.

Is it a risky business to move the already site I have been training, learning and modifying in 4 months now to another web host? How do we even do that?
Anyone you could recommend that doesnt has these problems?

Whats important for me, is that I am new to this and I am scared to death that the site is going to crash like 2 weeks after we are launching and then the owners will go after me. So I need a web host that can hel me understand the risks, and prevent me to go there. The web host I have been having have done basic on this point so I actually quite feel that I should have someone else. And now I have you as the backup-discussion :slight_smile: But I hope you get the point of trying to pre-find common issues that can go wrong and work in a way so they don’t happen (instead of blowing out fires as they arise during the time)

:ok_hand:
Maia

0 Likes

#11

Hi Craig,

After back and forth in 3 hours it seems that they could fix it. So now I managed the whole code like this:

composer update mageplaza/magento-2-swedish-language-pack:dev-master
bin/magento setup:di:compile
bin/magento setup:static-content:deploy en_US sv_SE -f
bin/magento indexer:reindex
bin/magento cache:clean
bin/magento cache:flush

The only one I cannot add is

redis-cli flushall

It seems to be a admin thing since I get this message:

Could not connect to Redis at 127.0.0.1:6379: Connection refused

But anyway, I still get this access error in front end

1 exception(s):
Exception #0 (InvalidArgumentException): Unable to serialize value.

Exception #0 (InvalidArgumentException): Unable to serialize value.
#0 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Translate.php(514): Magento\Framework\Serialize\Serializer\Json->serialize(Array)
#1 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Translate.php(223): Magento\Framework\Translate->_saveCache()
#2 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Area.php(245): Magento\Framework\Translate->loadData('frontend', false)
#3 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Area.php(216): Magento\Framework\App\Area->_initTranslate()
#4 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Area.php(143): Magento\Framework\App\Area->_loadPart('translate')
#5 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/DesignLoader.php(55): Magento\Framework\App\Area->load('translate')
#6 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Action/Plugin/Design.php(48): Magento\Framework\View\DesignLoader->load()
#7 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(121): Magento\Framework\App\Action\Plugin\Design->beforeDispatch(Object(Magento\Catalog\Controller\Product\View\Interceptor), Object(Magento\Framework\App\Request\Http))
#8 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Catalog\Controller\Product\View\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#9 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Catalog/Controller/Product/View/Interceptor.php(26): Magento\Catalog\Controller\Product\View\Interceptor->___callPlugins('dispatch', Array, Array)
#10 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/FrontController.php(159): Magento\Catalog\Controller\Product\View\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#11 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/FrontController.php(99): Magento\Framework\App\FrontController->processRequest(Object(Magento\Framework\App\Request\Http), Object(Magento\Catalog\Controller\Product\View\Interceptor))
#12 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\App\FrontController->dispatch(Object(Magento\Framework\App\Request\Http))
#13 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\App\FrontController\Interceptor->___callParent('dispatch', Array)
#14 /kunder/wpspku_3014/magent_5277/public/vendor/magento/module-store/App/FrontController/Plugin/RequestPreprocessor.php(94): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#15 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(135): Magento\Store\App\FrontController\Plugin\RequestPreprocessor->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#16 /kunder/wpspku_3014/magent_5277/public/vendor/magento/module-page-cache/Model/App/FrontController/BuiltinPlugin.php(73): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#17 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(135): Magento\PageCache\Model\App\FrontController\BuiltinPlugin->aroundDispatch(Object(Magento\Framework\App\FrontController\Interceptor), Object(Closure), Object(Magento\Framework\App\Request\Http))
#18 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\App\FrontController\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Request\Http))
#19 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/App/FrontController/Interceptor.php(26): Magento\Framework\App\FrontController\Interceptor->___callPlugins('dispatch', Array, NULL)
#20 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Http.php(135): Magento\Framework\App\FrontController\Interceptor->dispatch(Object(Magento\Framework\App\Request\Http))
#21 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#22 /kunder/wpspku_3014/magent_5277/public/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))
#23 {main}

So I would be truly THANKFUL if you could take a lok at this tonight and try it at your place.

Thanks
:smiley_cat:

0 Likes

#12

I’m planning on doing a Web Host review in a few weeks. I did a Google search for “Magento Web Hosts” and I’m going to go through about 8 of them to see what they are like. Now obviously, those search results will be aimed at my location (UK) so I don’t know what the service will be like for your situation. However, the reviews might help you know what to look out for when doing your own research.

Personally, I had an excellent experience using Nexcess (SIP-100 Starter Package) when I first got into Magento.

If you’re going to switch Web Hosts, you’re better off doing it before your go live. For the most part, what you’ve learned about the Server/Magento shouldn’t change from Web Host to Web Host. The only variations you might find are with their “Portals”. You’re going to find problems with any setup. What matters is How they handle problems. You should always have a plan for when things go wrong. For example, I had downtime myself today (out of nowhere). It was a combination of me checking through Magento and my Web Hosts checking through the server to spot the cause of the issue… That we never did :confused: .

For me, I’m pretty competent (but no expert). So, my Web Hosts requirements were specific to the following:

  • What happens when downtime occurs
  • Can I ring a human being when I have an urgent issue (24/7)
  • Do I get access to an expert to help me set things up when I need them
  • Is our server capable of exponential growth
  • Does the Web Host work for me? Or am I getting minimal support.
0 Likes

#13

I’ll get back to you tonight.

0 Likes

#14

So, I’m running a clean install of 2.3.1 and I’m sitting in Developer Mode. I ran the following:

composer require mageplaza/magento-2-swedish-language-pack:dev-master
php bin/magento setup:static-content:deploy en_US sv_SE -f
php bin/magento indexer:reindex
php bin/magento cache:clean
php bin/magento cache:flush

Then I set Stores > Configuration > General > Locale Options > Locale = Swedish (Sweden) and cleared the cache.

Then I refreshed the Frontend and everything loads as I’d expect.

This could be a conflict with another module. The original error message mentions “CleverSoft\CleverBuilder”. I don’t know what that is. It could be related to your problem or might not have anything to do with it.

Out of curiosity, do you get them same issue when you change your store to the Default Luma theme? That would be a good test to see if it’s Theme related.

0 Likes

#15

Thanks! I’ll check and get back to you.

0 Likes

#16

Thank you Craig! So I suppose no issue with the language pack.

2 things: “CleverSoft\CleverBuilder ”. Its from the Theme Developers, its a drag-and-drop designbuilder tool only for home pages in this case.

When I enter CONTENT > Design > Configuration . and go into the storeview “Svenska” and change theme to Luma in the dropdown its just turning out this way in the live URL. It is just displaying this text:

<link rel="stylesheet" media="all" href="//magent-5277.bolt54.servebolt.com/pub/media/cleversoft/web/css/_config/clever_headerbuilder_style_.css" />

<style>
.product pricing {
display: none;
}

</style><script>
    window.enable_sticky_menu = '1';
    window.enable_sticky_addtocart = '0';
    window.stickyThumbGallery = 'vertical_thumb';
</script>
<header class="page-header  lightbox  lightbox " id="page-header">
                <div class="show-on-mobile page-header-mobile d-lg-none">
                        <!-- Mobile -->
            
                            <!-- header main -->
                <div id="sticky-headers__mobile" class="header_main-mobile">
                    <div class="header_main-mobile-top " id="header-sticky-mobile">
                        <div class="container">
                            <div class="row main-menu_relative">
1 exception(s):
Exception #0 (Magento\Framework\Exception\ValidatorException): Invalid template file: 'Magento_Search::form.mini-mobile.phtml' in module: 'CleverSoft_CleverSearchAutoComplete' block's name: 'top.search.mobile'

Exception #0 (Magento\Framework\Exception\ValidatorException): Invalid template file: 'Magento_Search::form.mini-mobile.phtml' in module: 'CleverSoft_CleverSearchAutoComplete' block's name: 'top.search.mobile'
#0 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(301): Magento\Framework\View\Element\Template->fetchView(false)
#1 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(668): Magento\Framework\View\Element\Template->_toHtml()
#2 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(557): Magento\Framework\View\Element\AbstractBlock->toHtml()
#3 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(533): Magento\Framework\View\Layout->_renderBlock('top.search.mobi...')
#4 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('top.search.mobi...')
#5 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('top.search.mobi...')
#6 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('top.search.mobi...', true)
#7 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(508): Magento\Framework\View\Layout\Interceptor->renderElement('top.search.mobi...', true)
#8 /kunder/wpspku_3014/magent_5277/public/app/code/CleverSoft/CleverTheme/Block/Template.php(318): Magento\Framework\View\Element\AbstractBlock->getChildHtml('top.search-mobi...')
#9 [internal function]: CleverSoft\CleverTheme\Block\Template->renderRow(Array, '', 'mobile')
#10 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/TemplateEngine/Php.php(82): call_user_func_array(Array, Array)
#11 /kunder/wpspku_3014/magent_5277/public/app/code/CleverSoft/CleverTheme/view/frontend/templates/html/header.phtml(65): Magento\Framework\View\TemplateEngine\Php->__call('renderRow', Array)
#12 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/TemplateEngine/Php.php(59): include('/kunder/wpspku_...')
#13 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(271): Magento\Framework\View\TemplateEngine\Php->render(Object(CleverSoft\CleverTheme\Block\Template), '/kunder/wpspku_...', Array)
#14 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(301): Magento\Framework\View\Element\Template->fetchView('/kunder/wpspku_...')
#15 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(668): Magento\Framework\View\Element\Template->_toHtml()
#16 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(557): Magento\Framework\View\Element\AbstractBlock->toHtml()
#17 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(533): Magento\Framework\View\Layout->_renderBlock('mt_header')
#18 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('mt_header')
#19 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('mt_header')
#20 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('mt_header', false)
#21 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('mt_header', false)
#22 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('page.wrapper', false)
#23 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('page.wrapper')
#24 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('page.wrapper')
#25 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('page.wrapper', false)
#26 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('page.wrapper', false)
#27 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('root', false)
#28 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('root')
#29 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('root')
#30 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('root', true)
#31 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(954): Magento\Framework\View\Layout\Interceptor->renderElement('root')
#32 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\View\Layout->getOutput()
#33 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\View\Layout\Interceptor->___callParent('getOutput', Array)
#34 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\View\Layout\Interceptor->Magento\Framework\Interception\{closure}()
#35 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(494): Magento\Framework\View\Layout\Interceptor->___callPlugins('getOutput', Array, Array)
#36 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Result/Page.php(258): Magento\Framework\View\Layout\Interceptor->getOutput()
#37 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Result/Layout.php(171): Magento\Framework\View\Result\Page->render(Object(Magento\Framework\App\Response\Http\Interceptor))
#38 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\View\Result\Layout->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#39 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\View\Result\Page\Interceptor->___callParent('renderResult', Array)
#40 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\View\Result\Page\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Response\Http\Interceptor))
#41 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Result/Page/Interceptor.php(130): Magento\Framework\View\Result\Page\Interceptor->___callPlugins('renderResult', Array, Array)
#42 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Http.php(139): Magento\Framework\View\Result\Page\Interceptor->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#43 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/App/Http/Interceptor.php(24): Magento\Framework\App\Http->launch()
#44 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http\Interceptor->launch()
#45 /kunder/wpspku_3014/magent_5277/public/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))
#46 {main}

I am confused…Please try to help me.

0 Likes

#17

Did you clear cache etc after updating to Luma?

0 Likes

#18

Hi Craig,
Thanks for the advice. After changing Design - Configuration - Theme to Novetty Luma I went to Putty and wrote:

magento cache:clean
magento cache:flush 

Then I enter into the URL again and then this text is shown again:

<link rel="stylesheet" media="all" href="//magent-5277.bolt54.servebolt.com/pub/media/cleversoft/web/css/_config/clever_headerbuilder_style_.css" />

<style>
.product pricing {
display: none;
}

</style><script>
    window.enable_sticky_menu = '1';
    window.enable_sticky_addtocart = '0';
    window.stickyThumbGallery = 'vertical_thumb';
</script>
<header class="page-header  lightbox  lightbox " id="page-header">
                <div class="show-on-mobile page-header-mobile d-lg-none">
                        <!-- Mobile -->
            
                            <!-- header main -->
                <div id="sticky-headers__mobile" class="header_main-mobile">
                    <div class="header_main-mobile-top " id="header-sticky-mobile">
                        <div class="container">
                            <div class="row main-menu_relative">
1 exception(s):
Exception #0 (Magento\Framework\Exception\ValidatorException): Invalid template file: 'Magento_Search::form.mini-mobile.phtml' in module: 'CleverSoft_CleverSearchAutoComplete' block's name: 'top.search.mobile'

Exception #0 (Magento\Framework\Exception\ValidatorException): Invalid template file: 'Magento_Search::form.mini-mobile.phtml' in module: 'CleverSoft_CleverSearchAutoComplete' block's name: 'top.search.mobile'
#0 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(301): Magento\Framework\View\Element\Template->fetchView(false)
#1 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(668): Magento\Framework\View\Element\Template->_toHtml()
#2 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(557): Magento\Framework\View\Element\AbstractBlock->toHtml()
#3 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(533): Magento\Framework\View\Layout->_renderBlock('top.search.mobi...')
#4 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('top.search.mobi...')
#5 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('top.search.mobi...')
#6 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('top.search.mobi...', true)
#7 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(508): Magento\Framework\View\Layout\Interceptor->renderElement('top.search.mobi...', true)
#8 /kunder/wpspku_3014/magent_5277/public/app/code/CleverSoft/CleverTheme/Block/Template.php(318): Magento\Framework\View\Element\AbstractBlock->getChildHtml('top.search-mobi...')
#9 [internal function]: CleverSoft\CleverTheme\Block\Template->renderRow(Array, '', 'mobile')
#10 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/TemplateEngine/Php.php(82): call_user_func_array(Array, Array)
#11 /kunder/wpspku_3014/magent_5277/public/app/code/CleverSoft/CleverTheme/view/frontend/templates/html/header.phtml(65): Magento\Framework\View\TemplateEngine\Php->__call('renderRow', Array)
#12 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/TemplateEngine/Php.php(59): include('/kunder/wpspku_...')
#13 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(271): Magento\Framework\View\TemplateEngine\Php->render(Object(CleverSoft\CleverTheme\Block\Template), '/kunder/wpspku_...', Array)
#14 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(301): Magento\Framework\View\Element\Template->fetchView('/kunder/wpspku_...')
#15 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(668): Magento\Framework\View\Element\Template->_toHtml()
#16 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(557): Magento\Framework\View\Element\AbstractBlock->toHtml()
#17 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(533): Magento\Framework\View\Layout->_renderBlock('mt_header')
#18 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('mt_header')
#19 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('mt_header')
#20 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('mt_header', false)
#21 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('mt_header', false)
#22 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('page.wrapper', false)
#23 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('page.wrapper')
#24 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('page.wrapper')
#25 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('page.wrapper', false)
#26 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('page.wrapper', false)
#27 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('root', false)
#28 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('root')
#29 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('root')
#30 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('root', true)
#31 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(954): Magento\Framework\View\Layout\Interceptor->renderElement('root')
#32 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\View\Layout->getOutput()
#33 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\View\Layout\Interceptor->___callParent('getOutput', Array)
#34 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\View\Layout\Interceptor->Magento\Framework\Interception\{closure}()
#35 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(494): Magento\Framework\View\Layout\Interceptor->___callPlugins('getOutput', Array, Array)
#36 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Result/Page.php(258): Magento\Framework\View\Layout\Interceptor->getOutput()
#37 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Result/Layout.php(171): Magento\Framework\View\Result\Page->render(Object(Magento\Framework\App\Response\Http\Interceptor))
#38 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\View\Result\Layout->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#39 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\View\Result\Page\Interceptor->___callParent('renderResult', Array)
#40 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\View\Result\Page\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Response\Http\Interceptor))
#41 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Result/Page/Interceptor.php(26): Magento\Framework\View\Result\Page\Interceptor->___callPlugins('renderResult', Array, Array)
#42 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Http.php(139): Magento\Framework\View\Result\Page\Interceptor->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#43 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#44 /kunder/wpspku_3014/magent_5277/public/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))
#45 {main}

I really need your help, I have some kind of deadline that I really want to deliver too. Thank you!

0 Likes

#19

I’m pretty sure this is an issue with the Cleversoft theme. Perhaps a bug or an incompatibility. What did the Theme Developers suggest?

0 Likes

#20

Thank you for the lead, actually by reading the answer from the Theme Developers it seems very strange to me s I’ll write them again and get back to you after that. The only thing they actually wrote that meant something was that they can charge 50 dollars for language pack installation :rofl: Thanks.

0 Likes