Fresh Install as per video, but CPU load maxed

Good morning folks

Firstly, Thanks to Craig for the Magento 2 video, by far the best I have seen. I have been running a Magento store for around 6 years now, ranging from 1.4 - 1.9. I have tried on numerous occasion to install Magento 2. but always hit far too many issues.

I have been running it on a VPS from Heart internet (2Gb), but no soon as I find a fix for one problem, I hit another.

I have decided now is the time I must make the move so following the video I have purchased a DigitalOcean account, set up a droplet ($20/month) and installed as per the video. Initially all worked well. I was able to enter the web setup wizard and began trying to install a module. (Heart VPS kept failing at dependency check due to ram despite being set at 2G). The DO server sailed through, but still failed the install. I then noticed that during the module installation the CRON issue I had before on was still there and it was no longer completing jobs and was filling up my MySql, which crashed then it. I deleted the cron jobs, restarted the MySql, was able to access phpmyadmin and empty the cron schedule, but now apache is maxing the CPU

Where do I go from there, why? and how do i get more info on what is doing ?

I have tired rebooting the server but soon as log into magento same happens again.

Hi @Sean_Lount and welcome,

I ran into this very issue multiple times in the past. The DO Droplet you have chosen is definitely cable of the job, so you don’t have to worry about that. If memory serves, this was a result of the PHP memory_limit being bottle-necked. This can cause a multitude of issues especially when it comes to running cron tasks. I remember my cron table filling up with tens of thousands of failed requests just like you.

At the end of the tutorial you mentioned, I go over updating the .htaccess file in order to increase the PHP memory_limit for PHP 7 from 756MG to 2GB. However, this file often gets “reset” during updates/upgrades so you end up having to put your change back in afterwards. This could be the case here.

Refer to “The Fix” in this post (Web Setup Wizard cannot pass: "Check Component Dependency"). Once you’ve made this change, you might still need to:

  1. Truncate cron_schedule
  2. Restart Apache (as superuser: sudo service apache restart)
  3. Wait 5 minutes for the server to catch up

Let me know how you get on.

Hi Craig,

Thank you for responding. I have done some more playing and found that when the module install failed, it has already disabled cache, I re-enabled and the issue screen shot’d above instantly went away… YAY.

However, when i go back into the Web Setup Wizard, it goes straight to the last stage with progress update and just says “update is already in progress”. Is there a way I rest this?

Update. I removed the .update and .setup files from the /var/ folder.

And the WSWizard was back to normal. I tried the install again (LiteMigration1to2) and was able to get much further this time. throught to the point it said it was disabling maintenance mode, but still failed and then site is broken, ie nothing when trying the addresses.

According to cl its filled the 4gb of memory, when i tried to use the “top” command I got this error?

PHP Fatal error: Out of memory (allocated 2097152) (tried to allocate 32768 bytes) in /var/www/html/vendor/magento/module-msrp-configurable-product/registration.php on line 1

Did you amend the PHP 7 memory_limit in the .htaccess? Just checking as you haven’t mentioned whether you did or didn’t.

Hi Craig

I did check the .htaccess file. it is still set a 3.5G

Well, there goes my theory. Your issue practically mirrored my experience too.

At this stage, it’s hard to narrow this down any further without digging around the server. Hopefully, this post gets spotted by someone else who have provide more information.