How to setup webmail under a different directory

Hi,
I have a dedicated server, and have installed Mag2.35 on Ubuntu 18.04 (pretty much by following the first set of DS videos. The site works well. I have installed POSTFIX because I wish to add e-mail to the domain. That works as well. Now I wish to add a webmail client. Here’s where I’m getting in the weeds.

I know that Magento needs to be the only thing in the /var/www/html directory. I am therefore trying to install roundcube into /var/www/roundcube. I have tried using rewrites to redirect the installer, but that’s not working. Here is what I added to the .htaccess file in the Magento root:

RewriteRule ^/roundcube/(.*) /var/www/roundcube/roundcubemail-1.3.8/$1 [QSA]

This gives me a 404 error, nicely handled by Magento.

My question is - am I totally on the wrong track, or am I failing with syntax or something?
Thanks
Mike

Pretty much. You need to implement Apache Virtual Hosts. This takes advantage of Apache redirecting traffic to specific traffic to specific directories. For example:

  • example.com points to /var/www/html/
  • webmail.example.com points to/var/www/roundcube/

Pretty simple to setup, but not something we cover here. I believe the article below will tell you all you need to know about it. If not, the procedure is well documented online.

References

Hi,

Thanks for the reply, Craig. I played around with what you suggested a bit. I didn’t quite get that working, but I’ve since ended up in the weeds.

I don’t know where things went off track, exactly, but I discovered that I couldn’t make simple changes to ‘Default Store View’ settings. For example, even trying to change the default page title does not take. It does not give me an error in Magento, it simply fails to update. I tried refreshing ownerships and permissions (as per your videos), but I still get the same result.

I have an old snapshot (from Aug 28) where everything works. I tried going back to that and restoring the database and media from the current version. Again, I get no error, it simply does not do the update.

Forgive me, also. I wasn’t sure if I should continue with this thread, or post it as a new topic. It may be that the two posts I have made are related, just not sure.

How should I go about troubleshooting this problem.
Thanks.