I can't connect to website after install Let’s Encrypt Free SSL, please help me!

after install Let’s Encrypt Free SSL for my website, i can’t connect to website, I using Magento 2.4.0. How do I fix it? Thank you!

Hi Duy,
If you post details of your server and setup then it will be easier for people on here to help you.

  1. Shared or Dedicated Server?
  2. Did your setup the server or install Magento yourself?
  3. What are your server specifications?
  4. What version of Magento are you using?
  5. Were you following the tutorial How to setup Let’s Encrypt Free SSL Certificate with Magento 2 ?
  6. Have you flushed your browser’s cache?
  7. Was the website working before you installed SSL? (Looking at the website address right now, I can see http 599 error, ERR_CONNECTION_TIMED_OUT which is not specific to an SSL issue)

Looking forward to your reply so we can provide you some help on your issue.
Thanks

Hi! thank you for reply

  1. I using Linuxoid Cloud of Flaunt7
  2. Yes, I installed it myself
  3. 2CPU- 8G Ram- 200g SSD
  4. I using Magento 2.4.0
  5. Yes, I followed the tutorial How to setup Let’s Encrypt Free SSL Certificate with Magento 2 ?
  6. I deleted browser’s cache and delete all cookie
  7. website working before I installed SSL, but after I installed SSL, it not working.
    I looking forward to your reply, thank you so much

Looks like you’ve got it working now?
Was it just a case of waiting for the SSL/DNS to proliferate or did you have to do something to get it working.
If you document your solution here it will help others in the future facing the same issue as you have had.

Don’t forget to update your Magento settings to it forces https for all visitors. I do it like this…

Stores > Configuration > General > Web
Base URLs
• Base URL = https://www.kingofapparel.com/
• Base Link URL = https://www.kingofapparel.com/

Base URLs (Secure)
• Use Secure URLs on Storefront = Yes
• Use Secure URLs in Admin = Yes
• Upgrade Insecure Requests = Yes
• Flush Cache and test by trying to paste in a http: page it should automatically change to https

1 Like

Yes, It working. Thank You

I setup Base URLs (Secure) before install Let’s Encrypt.