Installation Klarna Payment Method Problem

#1

Dear Craig and other DigitalStartup-members,
I recently found Craig’s youtube-videos, and honestly I havent seen anything so well-produced and informative for a long long time. As a young woman in the tech-biz I am very honored to be a member of this community and I hope you can help me here.

I try to install the Klarna Checkout (NOTKlarna Payment that is already pre-installed with the Magento-version-2.3). Klarna Checkout is a fixed solution that takes care of the whole shopping cart experience, popular in Scandinavia. Anyway, I face a problem in this installation in the Readiness Check in Web Wizard Setup as this photo:


The Check Component Dependancy is an error. There is no explanation of the error in the error log, from what I can read.
Firstly, how to solve this error? A honest developer I have been in contact for a year (found on Fiverr) says this is a conflict error and to install the Klarna Checkout he wants to go through the composer instead and then he needs sudo access chmod 777 to almost all root files. This I know is a security risk and it shouldnt take this to install a payment menthod? Klarna support confirms that it doesnt need to be done that way, it should be done thorugh the web wizard setup. Please advice, any idea where to start to solve the Check Component Dependancy error?
Thanks.

0 Likes

#2

Hi @MAIA1, glad to have you with us.

In order to help answer your question, where did you obtain the Klarna Checkout module from? Let me know and I should be able to offer some further advice.

@MohamedSuliman had the same issue (found here) a few days ago with a different module that he was trying to install via the Magento Marketplace. We discovered that the version on the Marketplace was an old version that possibly wasn’t compatible with Magento 2.3. So, instead he installed it via composer directly from the developers own repository (which was up-to-date).

Installing/Updating Modules
Personally, I always use Composer (when possible) to install and update modules. The process is quicker and tends to be more reliable. Obviously, this method isn’t for everyone as the Command Line Interface can seem overwhelming at first.

Permissions
777 is never the solution to a problem. If you need to change folder/file permissions to 777 then there is a deeper issue somewhere else. The consequences of 777 can easily result in malicious activity to your website resulting in either the destruction of your store - or worse - a breach of your customer data.

0 Likes

#3

I had a spare few minutes to look into this further.

Assuming that you are getting the Klarna Payments module via Magento Marketplace, the Overview says:

NOTE: This extension is for Magento 2.1.x only. For Magneto 2.2.x support (both Commerce and Open Source editions) please install/upgrade to 2.2.4 or higher and Klarna Payments is installed for you as part of the core Magento offering.

So I checked the settings in Magento and Klarna is now included with Magento by default. You can find the settings under System > Configuration > Sales > Payment Methods > Other Payment Methods.

Here is the setup information in the Official Magento Documentation.

So, it looks like you don’t need to do anything.

0 Likes

#4

Dear Craig,
Thank you so much for investigating this.

  1. It is a developer that I found on Fiverr that requests the 777 access and that makes me nervous. But I am desperate and need to find a solution to install the Klarna Checkout Payment Method so thats why I mentioned it. However, I’ll follow your advice to not give the 777 access.

  2. Thank you for taking your spare minutes to check this. I was not clear enough here I think, Klarna offers 2 different extensions in the Marketplace. Number 1 is the Klarna Payment that you refered to, which correctly is pre-installed. No need for a setup. The second is Klarna Checkout https://marketplace.magento.com/klarna-m2-checkout.html which has become popular in Sweden for the last months, and this is the extension that I want. I have already setup my account with the Klarna Checkout, but I cannot manage to install it through the Web Wizard Setup because of the problem in this installation in the Readiness Check.

FYI

  • Have you installed anything via the Web Setup Wizard before? No
  • What version of Magento 2 are you running? 2.3
  • Was Magento originally installed by you ( from scratch) or by your Web Host? My Web Host
  • Is this a Live or Development environment? Its not live

, I have checked the requirements and I installed the right 2.3 version of Communityedition and I have the right PHP-version. So now I am left to the un-known :wink:

Your reply is so highly appreciated :pray:

0 Likes

#5

So, I tried to install Klarna Checkout on my Magento 2.3 instance via the Web Setup Wizard and ran into the same problem that you had (except my output showed the problem for some reason).

We found conflicting component dependencies. Hide detail

Command "update" failed: Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- klarna/module-core 3.0.0 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.7 || 100.2.0 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0].
- klarna/module-core 3.1.0 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.7 || 100.2.0 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0].
- klarna/module-core 3.1.1 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.8 || 100.2.0 - 100.2.1 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0, 100.1.8, 100.2.1].
- klarna/module-core 3.2.2 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.8 || 100.2.0 - 100.2.1 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0, 100.1.8, 100.2.1].
- klarna/module-core 3.2.3 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.8 || 100.2.0 - 100.2.1 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0, 100.1.8, 100.2.1].
- klarna/module-core 3.2.4 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.8 || 100.2.0 - 100.2.1 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0, 100.1.8, 100.2.1].
- klarna/module-core 3.2.5 requires magento/module-payment 100.0.0 - 100.0.12 || 100.1.0 - 100.1.8 || 100.2.0 - 100.2.1 -> satisfiable by magento/module-payment[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.1.0, 100.1.1, 100.0.7, 100.1.2, 100.1.3, 100.0.8, 100.1.4, 100.0.9, 100.1.5, 100.0.10, 100.0.11, 100.1.6, 100.1.7, 100.0.12, 100.2.0, 100.1.8, 100.2.1].
- klarna/module-ordermanagement 4.1.3 requires php ^5.6|~7.0.13|~7.1.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- klarna/module-ordermanagement 4.1.2 requires php ^5.6|~7.0.13|~7.1.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- klarna/module-ordermanagement 4.1.0 requires php ^5.6|~7.0.13|~7.1.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.2.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.8 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.2.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.12 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.6 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.11 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.10 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.5 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.9 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.4 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.8 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.3 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.2 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.7 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.1 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.1.0 requires php ~5.6.0|7.0.2|~7.0.6 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.6 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.5 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.4 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.3 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- magento/module-payment 100.0.2 requires php ~5.5.0|~5.6.0|~7.0.0 -> your PHP version (7.2.13) does not satisfy that requirement.
- klarna/module-om 3.0.7 requires klarna/module-core ^3.0 -> satisfiable by klarna/module-core[3.0.0, 3.1.0, 3.1.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5].
- Installation request for klarna/module-om 3.0.7 -> satisfiable by klarna/module-ordermanagement[4.1.0, 4.1.2, 4.1.3], klarna/module-om[3.0.7].

Judging by the output, it’s clear that there’s an issue with PHP compatibility. This suggests that it’s trying to install something that’s not compatible with the Magento 2.3 environment.

Composer Method

So, I tried doing it via Composer (which is the way I’d usually do it). I did this by running the following command as the magento user from the Magento root directory:

composer require klarna/m2-checkout:7.0.0

And as you can see, everything installed correctly with no errors

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 8 installs, 0 updates, 0 removals
  - Installing klarna/module-kco-core (6.0.0): Downloading (100%)
  - Installing klarna/module-kco-ordermanagement (6.0.0): Downloading (100%)
  - Installing klarna/module-kco (7.0.0): Downloading (100%)
  - Installing klarna/checkout (v4.0.0): Downloading (100%)
  - Installing phpxmlrpc/phpxmlrpc (4.3.1): Downloading (100%)
  - Installing klarna/php-xmlrpc (v5.0.0): Downloading (100%)
  - Installing klarna/module-kred (6.0.0): Downloading (100%)
Package phpunit/phpunit-mock-objects is abandoned, you should avoid using it. No replacement was suggested.
Writing lock file
Generating autoload files

Further Investigation

After the module installed correctly via Composer, I compared the modules that were installed against the modules that were showing available in the Web Setup Wizard. And it appears that the Web Setup Wizard allows you to install both the 2.2 and 2.3 compatible versions at the same time - Which was causing the issue.

Now knowing this, I wanted to see if I could install Klarna Checkout via the Web Setup Wizard by only selecting the modules I know I needed.

klarna

And I can confirm that omitting incompatible modules let me install Klarna Checkout without any issues.

klarna2

Conclusion
The issues you seem to have faced so far are nothing you have done wrong. It’s just poor implementation by Klarna. Give it a go and let me know how you get on.

0 Likes

#6

Dear Craig,

I am totally overwhelmed of the useful information that you provides and the time that you put to find a solution. A big eloge to you!

I followed every step you made and they all make sense. Unfortunately it didn’t work out for me, facing these errors:

Through Web Wizard: I select the same as you mentioned in your answer but I still face the same problem, I got an red error on Check Component Dependency.

So I started Putty and did the other way like this:

-bash-4.2$ ls -la
total 80
drwxr-x--- 12 magent_5137 wpspku_3014  4096 Mar  3 12:00 .
drwxr-xr-x  4 root        wpspku_3014  4096 Feb 23 17:05 ..
-rw-------  1 magent_5137 wpspku_3014  6444 Mar 12 18:01 .bash_history
-rw-r--r--  1 magent_5137 wpspku_3014    60 Feb 23 17:12 .bash_profile
-rw-r--r--  1 magent_5137 wpspku_3014   231 Feb 23 17:05 .bashrc
drwxr-xr-x  3 magent_5137 wpspku_3014  4096 Mar  9 11:40 .composer
drwx------  2 magent_5137 wpspku_3014  4096 Mar 13 04:03 logs
drwx------  2 magent_5137 wpspku_3014  4096 Feb 23 17:05 pagespeed-cache
drwx------  2 magent_5137 wpspku_3014 20480 Mar 12 16:42 php-session
drwx------  2 magent_5137 wpspku_3014  4096 Feb 23 17:05 php-upload
drwxrw----  3 magent_5137 wpspku_3014  4096 Mar  3 12:00 .pki
drwx------  2 magent_5137 wpspku_3014  4096 Feb 23 17:05 private
drwxrwxrwx 17 magent_5137 wpspku_3014  4096 Mar 12 17:33 public
drwx------  2 magent_5137 wpspku_3014  4096 Feb 23 17:06 .ssh
drwx------  2 magent_5137 wpspku_3014  4096 Feb 23 17:05 tmp
-bash-4.2$ cd public
-bash-4.2$ composer require klarna/m2-checkout:7.0.0
Could not scan for classes inside "/kunder/wpspku_3014/magent_5137/public/vendor/phpunit/phpunit/src/" which does not appear to be a file nor a folder
Could not scan for classes inside "/kunder/wpspku_3014/magent_5137/public/vendor/phpunit/phpunit/src/" which does not appear to be a file nor a folder
./composer.json has been updated
Could not scan for classes inside "/kunder/wpspku_3014/magent_5137/public/vendor/phpunit/phpunit/src/" which does not appear to be a file nor a folder
Could not scan for classes inside "/kunder/wpspku_3014/magent_5137/public/vendor/phpunit/phpunit/src/" which does not appear to be a file nor a folder
Loading composer repositories with package information
Updating dependencies (including require-dev)
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-magento$module-webapi.json into cache failed after 364544 of 836539 bytes written, only 239038730240 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-magento$module-webapi-security.json into cache failed after 331776 of 413581 bytes written, only 239038697472 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-magento$module-weee.json into cache failed after 331776 of 836539 bytes written, only 239038697472 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-magento$theme-adminhtml-backend.json into cache failed after 188416 of 836539 bytes written, only 239038550016 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-magento$theme-frontend-blank.json into cache failed after 188416 of 836539 bytes written, only 239038550016 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-magento$theme-frontend-luma.json into cache failed after 188416 of 718102 bytes written, only 239038545920 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-zendframework$zend-feed.json into cache failed after 45056 of 399394 bytes written, only 239038398464 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-zendframework$zend-mail.json into cache failed after 45056 of 374879 bytes written, only 239038398464 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-zendframework$zend-mime.json into cache failed after 45056 of 339374 bytes written, only 239038398464 bytes of free space available
Writing /kunder/wpspku_3014/magent_5137/.composer/cache/repo/https---repo.packagist.org/provider-symfony$polyfill-php56.json into cache failed after 32768 of 2809097 bytes written, only 239038332928 bytes of free space available
Package operations: 9 installs, 11 updates, 1 removal
  - Removing symfony/contracts (v1.0.2)
Removing Symfony/Contracts
  - Downgrading magento/inventory-composer-installer (1.1.0 => 1.0.3): Loading from cache
  - Downgrading symfony/stopwatch (v4.2.4 => v4.1.8): Downloading (100%)
  - Downgrading symfony/process (v4.1.11 => v4.1.8): Downloading (100%)
  - Downgrading symfony/options-resolver (v4.2.4 => v4.1.8): Downloading (100%)
  - Downgrading symfony/finder (v4.2.4 => v4.1.8): Downloading (100%)
  - Downgrading symfony/filesystem (v4.2.4 => v4.1.8): Downloading (100%)
  - Downgrading symfony/event-dispatcher (v4.1.11 => v4.1.8): Downloading (100%)    Failed to execute unzip -qq  '/kunder/wpspku_3014/magent_5137/public/vendor/symfony/event-dispatcher/72ed57eb87ddb768d5776cb740870ed2' -d '/kunder/wpspku_3014/magent_5137/public/vendor/composer/5952e866'

/kunder/wpspku_3014/magent_5137/public/vendor/composer/5952e866/symfony-event-dispatcher-8b93ce0/Tests/EventDispatcherTest.php:  write error (disk full?). Continue? (y/n/^C)
warning:  /kunder/wpspku_3014/magent_5137/public/vendor/composer/5952e866/symfony-event-dispatcher-8b93ce0/Tests/EventDispatcherTest.php is probably truncated

    The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems)
    Unzip with unzip command failed, falling back to ZipArchive class

  - Downgrading symfony/console (v4.1.11 => v4.1.8): Downloading (100%)    Failed to execute unzip -qq  '/kunder/wpspku_3014/magent_5137/public/vendor/symfony/console/ec90b857a5bfea89951ad4d06b2137a3' -d '/kunder/wpspku_3014/magent_5137/public/vendor/composer/80f91631'

/kunder/wpspku_3014/magent_5137/public/vendor/composer/80f91631/symfony-console-c74f4d1/Tests/Fixtures/input_definition_3.md:  write error (disk full?).  Continue? (y/n/^C)
warning:  /kunder/wpspku_3014/magent_5137/public/vendor/composer/80f91631/symfony-console-c74f4d1/Tests/Fixtures/input_definition_3.md is probably truncated

    The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems)
    Unzip with unzip command failed, falling back to ZipArchive class
    Update failed (The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems): ZipArchive::extractTo(/kunder/wpspku_3014/magent_5137/public/vendor/composer/80f91631/symfony-console-c74f4d1/Tests/Fixtures/input_option_6.xml): failed to open stream: Disk quota exceeded)
    Would you like to try reinstalling the package instead [yes]? yes
  - Removing symfony/console (v4.1.11)
  - Installing symfony/console (v4.1.8): Downloading (100%)
    Failed to execute unzip -qq  '/kunder/wpspku_3014/magent_5137/public/vendor/symfony/console/ec90b857a5bfea89951ad4d06b2137a3' -d '/kunder/wpspku_3014/magent_5137/public/vendor/composer/cee15057'

/kunder/wpspku_3014/magent_5137/public/vendor/composer/cee15057/symfony-console-c74f4d1/Tests/Fixtures/application_2.json:  write error (disk full?).  Continue? (y/n/^C)
warning:  /kunder/wpspku_3014/magent_5137/public/vendor/composer/cee15057/symfony-console-c74f4d1/Tests/Fixtures/application_2.json is probably truncated

    The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems)
    Unzip with unzip command failed, falling back to ZipArchive class
    Failed to download symfony/console from dist: The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems): ZipArchive::extractTo(/kunder/wpspku_3014/magent_5137/public/vendor/composer/cee15057/symfony-console-c74f4d1/Tests/Fixtures/input_option_6.xml): failed to open stream: Disk quota exceeded
    Now trying to download from source
  - Installing symfony/console (v4.1.8): Cloning c74f4d1988
The authenticity of host 'github.com (192.30.253.112)' can't be established.
RSA key fingerprint is SHA256:nThbg6kXUpJWGl7E1IGOCspRomTxdCARLviKw6E5SY8.
RSA key fingerprint is MD5:16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48.
Are you sure you want to continue connecting (yes/no)? yes


  [RuntimeException]
  Failed to clone https://github.com/symfony/console.git via https, ssh protocols, aborting.

  - https://github.com/symfony/console.git
    fatal: write error: Disk quota exceeded

  - git@github.com:symfony/console.git
    Warning: Permanently added 'github.com,192.30.253.112' (RSA) to the list of known hosts.
    Permission denied (publickey).
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

-bash-4.2$

But it didn’t work either. And now I cannot access to my Magento Admin Dashboard :frowning:

This leaves me little bit confused. I am so thankful for your guidance and advice. Thank you for bringing problems to the light and letting us “not-so-experienced-in-Magento” have a chance!! :pray::pray:

0 Likes

#7

So, it looks like you ran the composer command from the correct directory (assuming that Magento is installed in the public/ folder that you changed to) :+1:

The rest of the output is totally not what I would have ever expected to see. The line below makes me question that Magento was installed successfully, but I’m not really sure.

Could not scan for classes inside "/kunder/wpspku_3014/magent_5137/public/vendor/phpunit/phpunit/src/" which does not appear to be a file nor a folder

Then this line was interesting, as it seems to indicate that you ran out of disk space on your server so some files were unable to unzip.

failed to open stream: Disk quota exceeded

It probably wasn’t the best idea to confirm ‘yes’ at all the prompts, as it seems like you’ve gone down the rabbit hole here.

We could work out how to fix this but it would be much quicker to load a recent backup and start over.

0 Likes

#8

Dear Craig,

This was a shame as I would have stopped, what I understand from your message. Thank you for the constructive critic. Now I got desperate, I checked with my hosting company and they havent got any backup from my site yet!! So I am totally left out there. I dont have anything to restore (I thought I have, but they backup once a week and I started Monday so…). Please please please can we work out how to fix this? I put so many hours in installation of the theme. Thank you for your understanding. It would mean the world to me since I am a young woman trying to find a place in the tech industry, working on developing my own business and this site is the core of the business start. Thanks again.

Maia

0 Likes

#9

You might want to take this opportunity to improve your backup schedules. In a Production environment I do both Daily and Weekly backups. In a Development environment, I run a backup at the beginning of each big session in case I break something.

  • Did you check if you’d run out of disk space?
  • What error do you see when you attempt to load the backend?
  • If you haven’t already, set Magento to Developer Mode. This mode shows you error messages that you don’t normally have access to.

You can set Developer Mode by running the below command from the Magento root directory:

bin/magento deploy:mode:set developer
0 Likes

#10

Dear Craig,
Thank you for your professional advice. I really will proceed the backup schedules.
Do you have a linc/article/youtube-video about how to backup properly and completely?

Also, luckily, my husband had done a backup so now I have completely started on a new page and dont need to struggle with the old “rabbit-hole-experience” I had from the tryout to install Klarna.

But still, on the backuped version I get the same problem in the composer in Putty. And I cannot install it through the Web Wizard Setup so before I put “yes” this time in Putty - I check with the pro - you! :smiley:

0 Likes

#11

Backups
No, I haven’t done a video on backups, because the “How-to” part is totally different with each Web Host. But the general schedule I use is as follows in a Production Environment:

  • Daily Database Backups
  • Daily Incremental File Backups
  • Weekly Image Backups (AKA Snapshots)

And these take place during low-traffic hours in order to minimise disruption. And then I’ll do manual backups in both a Production and Development environment each time I:

  • Run an upgrade
  • Make any big changes

It sounds overkill, but in my line of work I can’t afford to have any downtime.

Back to the issue…
Going back to the issue at hand. Ignore the Putty method for now, as I was just explaining how I ran my investigation.

So, you still can’t get Klarna Checkout to install via the Web Setup Wizard even when you only select the following 5 modules? Is it the same issue as before?

klarna

I wonder if your Web Host did a bad job of installing your copy of Magento. Are you able to install this? It would be a good indicator to see if your Magento is the issue or the Klarna module.

0 Likes

#12

Backups
Thanks for the guidance, I will improve this. I now understand the importance of this.

Back to the issue…
Now from the backed up version, (a backup just recently done the day before I did the wrong try of the installation of Klarna Checkout), I tried to install Klarna again. Now I got error on everything :sweat: as you see here:


Do you have any advice where to go to understand how to solve these problems one by one. Cron Jobs are running well, no error logs what I can see and the Cron Jobs are setup by the hosting company. I have a good contact with the hosting company and their “service” is to provide a ready-to-go-installed basic version of Magento. So I cannot install it by myself with this hosting company (they are very known in Sweden so I dont think they should dare to do a bad job but lets see). Anyway, the have also setup the cron jobs like this through the hosting admin panel:

Thank you again for your support :pray:

0 Likes

#13

Okie dokie… So, when you see everything with a cross it means that the Cron Tasks weren’t able to do their job and run the checks. Which is exactly what you’ve referred to here :+1:

The difficulty lies with diagnosing your issue on a Shared Host. When you run your own dedicated server, you have absolute control over everything. But on a Shared Host, the Hosting Company partition the server and give everyone their own allocated portion. Therefore, all of the configuration settings of the server run a little differently from one host to the next.

A Dedicated Server
For example, on a dedicated server you would simply setup the cron tasks by running the following command from the Magento root directory:

bin/magento cron:install

This would install the following cron tasks:

* * * * * /usr/bin/php /var/www/html/bin/magento cron:run | grep -v Ran jobs by schedule >> /var/www/html/var/log/magento.cron.log
* * * * * /usr/bin/php /var/www/html/update/cron.php >> /var/www/html/var/log/update.cron.log
* * * * * /usr/bin/php /var/www/html/bin/magento setup:cron:run >> /var/www/html/var/log/setup.cron.log

A Shared Hosting Server
In your case, you can see that the 3 Cron Tasks look wildly different. And that’s because of the way your Web Host has decided to set up their servers. Therefore throwing in a load of “unknowns”.

Anyway, I’m not sure if the cron install command would work - But you can certainly try. But before you do, it looks like your 2/3 of your Magento Cron tasks are scheduled to trigger every 5 minutes. This should be every minute.

*/5 * * * * This means every 5 minutes
* * * * * This means every minute

Try amending the Times in the Cron Jobs to every minute. Wait a few minutes. Then try the Web Setup Wizard again.

Alternative Services
I’m not sure how invested you are to your Web Host. But can I recommend Nexcess.net SIP-100 Package? Simply because they are a Managed Hosting Company who specialise in Building Magento servers so that you don’t have to worry about any of this. They also have a 30-day money back guarantee if you decide you don’t want to stay with them. I used to use them before I started building Magento Servers from scratch and so I can’t recommend them highly enough. With your current issues, they would have supported you through them rather than leave you to it. I just thought I’d mention this on the off chance.

0 Likes

#14

Dear Craig,

Thank you for your support.

Alternative Services
Firstly, I will of course investigate Alternative Services as nexcess.net. Actually I am not invested much in the web host right now, I am just on an almost free trial. But this current web host is swedish and specialied in fast support and to load very fast website speed. How about support and speed in Nexcess?

A Shared Hosting Server
I have got very supported from the hosting service and they have changed the setup until running every minute. But the e-mails that are sent to me includes these:
email%20right

And that log says:
[2019-03-16 10:20:01] update-cron.ERROR: Cron readiness check failure! Found non-writable paths: /kunder/wpspku_3014/magent_5277/public/.htaccess.sample [] []

The next email error is:
email%20error

The web host says it is not an error on the server-side, more on the code-side. The nly things I have made to this website after the Magento-installation is to take help from a developer to install this theme:https://themeforest.net/item/novetty-fastest-most-customizable-magento-2-theme/18197526

So please help me understand and solve the issues.
Thank you very much.

0 Likes

#15

Alternative Services

Their web servers are optimised for Magento 2 installations. I’m pretty sure that would have done this for you - But don’t quote me on that. Troubleshooting this issue, would normally take an experienced user about 30 minutes or so. Naturally, it takes longer on here because we’re not speaking in real-time and I don’t have direct access to your server (not that this is something I would do).

Cron

[2019-03-16 10:20:01] update-cron.ERROR: Cron readiness check failure! Found non-writable paths: /kunder/wpspku_3014/magent_5277/public/.htaccess.sample [] []

Based on this entry, there’s a couple of scenarios:

  1. The Cron Tasks aren’t being executed as the correct user
  2. At some point either your File/Folder Ownerships or Permissions were changed

Check 1 (File/Folder Ownerships)
This first thing you’ll want to do is list the files/folders in your Magento root directory because it’ll tell you the Owner/Group and Permissions. You do that by running the following command from within the Magento root directory:

ls -la

You’ll get an output similar to this (bare in mind my example will differ slightly):

drwxr-xr-x  4 magento www-data   4096 Dec  9 00:05 app
-rw-r--r--  1 magento www-data    138 Dec  9 00:05 auth.json.sample
drwxr-xr-x  2 magento www-data   4096 Dec  9 00:05 bin
etc...

In my case (and anyone building Magento 2 from scratch who follows my tutorials) will have the File/Folder owner as “magento” and File/Folder Group as “www-data”. For Shared Hosting, I suspect (but don’t know for sure) that your File/Folder owner should be your SSH username. If this is the case then everything here is good :+1:

Check 2 (Cron Task Assignment)
When a Cron Task is run, it runs as the user who the task is setup under. So, let’s say that the Cron Task was setup under “Bob”, then when the Task was executed it wouldn’t have the necessary permission to edit the files it needs. In your case, it’s not likely the case but I figured I’d mention it just in case. To verify this is setup correctly, just check with your Web Host

Check 3 (File/Folder Permissions)
If I was a betting man, this is the one that I reckon will fix the Log Entry you shared. You’ll want to reset your File//Folder Permissions. Magento requires specific access to specific File and Folders on the server. As you can see in the Official Magento Documentation, there are specific instructions for Shared Hosting users. Carefully read through this document and take the necessary steps that allow you to update components and upgrade Magento.

0 Likes

#16

Hi Craig!
This was quite a time ago, since then I have been battling with Klarna :slight_smile:
However, now I finally made the installation of Klarna Checkout through the composer exactly as you wrote the code so that was a VERY APPECIATED GUIDE and everything seems fine until…

It was actually going to be tested :rofl:

So the site is live, I added aa product to the shopping cart and when I pushed “Checkout” I am supposed to get to a shopping cart that is “designed” by this extension/module Klarna Checkout. Is is supposed to look like this:

But instead I got this message:

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): \Klarna\KcoCore\Model\Checkout\Orderline\Items\Items class doesn't implement \Klarna\Core\Api\OrderLineInterface

Exception #0 (Magento\Framework\Exception\LocalizedException): \Klarna\KcoCore\Model\Checkout\Orderline\Items\Items class doesn't implement \Klarna\Core\Api\OrderLineInterface
#0 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-core/Model/Checkout/Orderline/Collector.php(137): Klarna\Core\Model\Checkout\Orderline\OrderLineFactory->create('\\Klarna\\KcoCore...')
#1 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-core/Model/Checkout/Orderline/Collector.php(108): Klarna\Core\Model\Checkout\Orderline\Collector->initModelInstance('\\Klarna\\KcoCore...', 'items')
#2 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-core/Model/Checkout/Orderline/Collector.php(77): Klarna\Core\Model\Checkout\Orderline\Collector->initCollectors(Object(Magento\Store\Model\Store\Interceptor))
#3 /kunder/wpspku_3014/magent_5277/public/generated/code/Klarna/Core/Model/Checkout/Orderline/Collector/Interceptor.php(24): Klarna\Core\Model\Checkout\Orderline\Collector->getCollectors(Object(Magento\Store\Model\Store\Interceptor))
#4 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-core/Model/Api/Builder.php(190): Klarna\Core\Model\Checkout\Orderline\Collector\Interceptor->getCollectors(Object(Magento\Store\Model\Store\Interceptor))
#5 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-core/Model/Api/Builder.php(176): Klarna\Core\Model\Api\Builder->collectOrderLines(Object(Magento\Store\Model\Store\Interceptor))
#6 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-kp/Model/Api/Builder/Kasper.php(115): Klarna\Core\Model\Api\Builder->generateRequest('create')
#7 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-kp/Model/Session.php(178): Klarna\Kp\Model\Api\Builder\Kasper->generateRequest('create')
#8 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-kp/Model/Session.php(164): Klarna\Kp\Model\Session->getGeneratedCreateRequest()
#9 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-kp/Model/Session.php(150): Klarna\Kp\Model\Session->initWithoutSession()
#10 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-kp/Model/Session.php(108): Klarna\Kp\Model\Session->requestKlarnaSession(NULL)
#11 /kunder/wpspku_3014/magent_5277/public/vendor/klarna/module-kp/Plugin/Checkout/Block/OnepagePlugin.php(70): Klarna\Kp\Model\Session->init()
#12 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(121): Klarna\Kp\Plugin\Checkout\Block\OnepagePlugin->beforeGetJsLayout(Object(Magento\Checkout\Block\Onepage\Interceptor))
#13 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Checkout\Block\Onepage\Interceptor->Magento\Framework\Interception\{closure}()
#14 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Checkout/Block/Onepage/Interceptor.php(26): Magento\Checkout\Block\Onepage\Interceptor->___callPlugins('getJsLayout', Array, Array)
#15 /kunder/wpspku_3014/magent_5277/public/app/design/frontend/CleverSoft/core/Magento_Checkout/templates/onepage.phtml(20): Magento\Checkout\Block\Onepage\Interceptor->getJsLayout()
#16 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/TemplateEngine/Php.php(59): include('/kunder/wpspku_...')
#17 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(271): Magento\Framework\View\TemplateEngine\Php->render(Object(Magento\Checkout\Block\Onepage\Interceptor), '/kunder/wpspku_...', Array)
#18 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Checkout/Block/Onepage/Interceptor.php(167): Magento\Framework\View\Element\Template->fetchView('/kunder/wpspku_...')
#19 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(301): Magento\Checkout\Block\Onepage\Interceptor->fetchView('/kunder/wpspku_...')
#20 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(668): Magento\Framework\View\Element\Template->_toHtml()
#21 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Checkout/Block/Onepage/Interceptor.php(466): Magento\Framework\View\Element\AbstractBlock->toHtml()
#22 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(557): Magento\Checkout\Block\Onepage\Interceptor->toHtml()
#23 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(533): Magento\Framework\View\Layout->_renderBlock('checkout.root')
#24 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('checkout.root')
#25 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('checkout.root')
#26 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('checkout.root', false)
#27 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('checkout.root', false)
#28 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('content', false)
#29 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('content')
#30 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('content')
#31 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('content', false)
#32 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('content', false)
#33 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('main.content.wr...', false)
#34 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('main.content.wr...')
#35 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('main.content.wr...')
#36 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('main.content.wr...', false)
#37 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('main.content.wr...', false)
#38 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('main', false)
#39 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('main')
#40 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('main')
#41 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('main', false)
#42 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('main', false)
#43 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('columns', false)
#44 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('columns')
#45 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('columns')
#46 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('columns', false)
#47 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('columns', false)
#48 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('main.content_sc...', false)
#49 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('main.content_sc...')
#50 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('main.content_sc...')
#51 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('main.content_sc...', false)
#52 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('main.content_sc...', false)
#53 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('main.content', false)
#54 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('main.content')
#55 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('main.content')
#56 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('main.content', false)
#57 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('main.content', false)
#58 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('page.wrapper', false)
#59 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('page.wrapper')
#60 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('page.wrapper')
#61 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('page.wrapper', false)
#62 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(585): Magento\Framework\View\Layout\Interceptor->renderElement('page.wrapper', false)
#63 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(535): Magento\Framework\View\Layout->_renderContainer('root', false)
#64 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(206): Magento\Framework\View\Layout->renderNonCachedElement('root')
#65 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(488): Magento\Framework\View\Layout\Interceptor->renderNonCachedElement('root')
#66 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(193): Magento\Framework\View\Layout->renderElement('root', true)
#67 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Layout.php(954): Magento\Framework\View\Layout\Interceptor->renderElement('root')
#68 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\View\Layout->getOutput()
#69 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\View\Layout\Interceptor->___callParent('getOutput', Array)
#70 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\View\Layout\Interceptor->Magento\Framework\Interception\{closure}()
#71 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Layout/Interceptor.php(494): Magento\Framework\View\Layout\Interceptor->___callPlugins('getOutput', Array, Array)
#72 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Result/Page.php(258): Magento\Framework\View\Layout\Interceptor->getOutput()
#73 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Result/Layout.php(171): Magento\Framework\View\Result\Page->render(Object(Magento\Framework\App\Response\Http\Interceptor))
#74 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(58): Magento\Framework\View\Result\Layout->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#75 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\View\Result\Page\Interceptor->___callParent('renderResult', Array)
#76 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/Interception/Interceptor.php(153): Magento\Framework\View\Result\Page\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Response\Http\Interceptor))
#77 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/View/Result/Page/Interceptor.php(130): Magento\Framework\View\Result\Page\Interceptor->___callPlugins('renderResult', Array, Array)
#78 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Http.php(139): Magento\Framework\View\Result\Page\Interceptor->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#79 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Framework/App/Http/Interceptor.php(24): Magento\Framework\App\Http->launch()
#80 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http\Interceptor->launch()
#81 /kunder/wpspku_3014/magent_5277/public/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http\Interceptor))
#82 {main}

And in Error Log it looks like this:

[Wed May 01 20:10:15 2019] [PID:1113253 EID:LIfXbQfdHMw] [php7:error:sapi_apache2.c(351)] [Host:magent-5277.bolt54.servebolt.com Client:90.142.60.51:0] PHP Fatal error:  Uncaught Error: Call to a member function getImageUrl() on null in /kunder/wpspku_3014/magent_5277/public/app/design/frontend/CleverSoft/core/Magento_Catalog/templates/category/image.phtml:25\nStack trace:\n#0 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/TemplateEngine/Php.php(59): include()\n#1 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(271): Magento\\Framework\\View\\TemplateEngine\\Php->render(Object(Magento\\Catalog\\Block\\Category\\View\\Interceptor), '/kunder/wpspku_...', Array)\n#2 /kunder/wpspku_3014/magent_5277/public/generated/code/Magento/Catalog/Block/Category/View/Interceptor.php(193): Magento\\Framework\\View\\Element\\Template->fetchView('/kunder/wpspku_...')\n#3 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/Template.php(301): Magento\\Catalog\\Block\\Category\\View\\Interceptor->fetchView('/kunder/wpspku_...')\n#4 /kunder/wpspku_3014/magent_5277/public/vendor/magento/framework/View/Element/AbstractBlock.php(668): Ma in /kunder/wpspku_3014/magent_5277/public/app/design/frontend/CleverSoft/core/Magento_Catalog/templates/category/image.phtml on line 25

Any idea? Thanks.
Maia

0 Likes

#17

Not sure. I see that the Theme is mentioned in the error. Might be worth doing what I said on the other post and checking if it works fine with Luma. If it does, then you might be better reaching out to the Theme Developers to help with your incompatibilities.

0 Likes

#18

Dear Craig,
Sounds like a proper analysis. But as I just recently wrote in the other thread, I cannot access the live site frontend when I activated Luma theme.
:frowning:

0 Likes

#19

I responded on other post

0 Likes

#20

I responded on the other thread as well, problem continues :frowning:

0 Likes