Issues creating a Child theme for Ultimo

Note: This conversation was moved from the Introduce Yourself Post. The conversation from this point focuses on the creation of an Ultimo Child Theme and some bugs that need ironing out

@DizzyLizzy, how did you get on with the Ultimo Child Theme? Just wondering in case I should take the time to look at it myself this weekend.

Hi Craig,

Apologies for the delay in replying, I was on holiday.

I have had a look this morning and it is helpful although I am still not clear on where this is actually placed in the folder structure.

Kind Regards,

Hi Craig, so I had another go and I am very sure I have created everything correctly this time and placed the files in the correct place however when I deploy the static files I get an error, well lots of errors actually but ultimately this is the final error … pub/static/frontend/Infortis/holly/en_GB/css/print.css): failed to open stream: No such file or directory

When I check that directory css is missing but all other folders seem to be there. I have tried searching for the answer but no joy, any ideas what I am doing wrong?

Howdie, @DizzyLizzy. No need to apologise for not getting back to me. If you’d like to share your Child Theme with me, then I’ll check it out for you. I just need a hot minute to spin up a server and install Ultimo.

Edit: I’ve built a server ready to try and reproduce your issue, as soon as you’re able to share your

Thanks Craig, child theme hopefully here

Good morning,

So far I’ve:

  • Installed your Child Theme
  • Switched to the Child Theme
  • Changed my store locale to United Kingdom

From this stage, I tried 2 methods to reproduce your issue…

Method 1
Manually Deployed Static Content (bin/magento setup:static-content:deploy en_GB -f)

Last few lines of output:

frontend/Infortis/base/en_GB            2269/2269           ============================ 100% %  0
frontend/Infortis/ultimo/en_GB          2271/2271           ============================ 100% %  1 sec
frontend/Infortis/holly/en_GB           2271/2271           ============================ 100% %  0

Execution time: 8.9472501277924

Method 2
Switch to Production Mode (I always run in Developer Mode) (bin/magento deploy:mode:set production)

Last few lines of output:

frontend/Infortis/ultimo/en_GB 2271/2271 ============================ 100% % 9 secs
frontend/Infortis/ultimo/en_US 2271/2271 ============================ 100% % 9 secs
frontend/Infortis/holly/en_GB 2271/2271 ============================ 100% % 9 secs
frontend/Infortis/holly/en_US 2271/2271 ============================ 100% % 9 secs

Execution time: 114.19210290909
Deployment of static content complete
Disabling maintenance mode
Enabled production mode.

It doesn’t appear I was able to reproduce your error. What steps did you take to reproduce it?

Hi Craig,

So I attempted to install the child theme again and managed it this time. I think I was failing to run the upgrade command after importing the files but it all works now. Thank you so much for your valuable help :slight_smile:

1 Like


Was going to offer you access to one of my sandbox servers (Vanilla install + Ultimo Child setup) if you were still struggling. Glad you nailed it :+1: Don’t be afraid to reach out if you get stuck again.

Thanks :slight_smile: