Magento 2.3.5 out of stock attribute is not crossed


I created a test configurable product and then placed maximum order on small size, so now product with size “S” is out of stock, but on front-end it does not show as crossed out. When I click it and place order then only it prompts that this item is out of stock.

I found that it was bug in 2.2.2, but I am using Magento 2.3.5-p1, so any solution for this?

Although, other sizes “M”,“L”, are in stock and i can order, but I suppose, “S” should be crossed out. Is there any specific settings for this?

I think an out-of-stock variation in a a Configurable Product is usually greyed out. I can’t remember off the top of my head. Have you tried Reindexing and clearing the cache in case the frontend is not in sync.

Yes did, I think i will have to edit some files to achieve this. but i am not sure where to begin, Also if a small size is out of stock, but medium and large is available, i dont think the whole product should be greyed out. isn’t this a bug then?

I’m pretty sure it’s only the dropdown box that should be greyed out when certain stock isn’t available on a configurable product. But I can’t check that right now.

Don’t know the reason of this, someone in Magento forum told me to use following extension to fix it, but I have not tried it yet, waiting for a reply from Claue theme support.

I had a problem with random sizes being out of stock on a configurable item.
Tried so many different things to get it working without success.
In the end, I recreated the configurable and associated the child items and all was well.
It might be worth a try.

Just a word to note, when setting up Configurable Products, the Child Products should be set to “Not Visible Individually”. Therefore, everything is set to focus on the Configurable Product as it should be set to “Catalog, Search”.

This solves most issues as it isn’t always obvious that it should be set this way. But dissecting the Sample Data (if you have this installed) should allow you to reverse engineer things like this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.