Magento 2.4 additional users

Hi Craig,
I wonder if you could help.

I successfully installed M2.4.1 following the tutorial

I had a few small issues but they were due to a lack of apostrophes and composer v2. Mag 2.4 doesn’t support it.

After I installed Mag. I received an email to set up 2FA with google authenticator.

Next, I installed a second Magento on the same server and parked it on 2 domain names for my store views. for English and for the French store view. This is very easy. Thanks to this tutorial.

It was all too easy. I got to steps now. I’m trying to set up some additional users with custom permissions. I created them at the Mag. admin panel but can’t use them. The following message is shown.

“Sorry, you need permissions to view this content.
Next steps
If you think this is an error, try signing out and signing in again.
Contact a system administrator or store owner to gain permissions.”

2nd user

I did research if it is a common issue and found this.

I added 2FA permission for the additional users but it didn’t help.


Then I decided to go around and try to create a second user with all administrator permissions and once created and active change his role to my custom permission roles.

I created the user via CLI
bin/magento admin:user:create

The new admin user has been created I see it in the Mag. admin panel but I can’t use it because I need to receive an email to set 2FA but I don’t get the email.

This ‘Postfix - a mail transfer agent’ which you recommended to install to be able to got through 2FA install process won’t handle email for my additional users?

I hope all it makes sense.

Can you please give me a tip on how to bit it?
Thank you in advance.


My environment: M2.4.1, hosting ovh - dedicated server, php 7.4, MySQL 8.0, ElasticSearch 7.6, 3 websites on one server (I don’t think that it will affect my emails all are enabled in /etc/apache2/sites-available/)

Not sure I can help you with this one. The only time I’ve ever used Postfix was to do the 2.4 tutorial - So, I’ve never had to debug or configure it. To get postfix working with apache virtual hosts, you’ll want to post that on something like or

Hi Craig,

Thank you.
I need to do research on it.

Hi Craig,
I tried today to install another sever and I had the same issue.
You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2

What is your suggestion?

@PawelP diable Magento twoFactorAuth by type: bin/magento module:disable Magento_TwoFactorAuth

1 Like

The solution for Composer is to install latest stable version 1.x by typing: composer self-update --1

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.