Order/shipment/invoice confirmation email bug

Hey everyone

I came across a bug in the above transactional emails (might affect Credit Memo email too but didn’t get that far in my testing) that drove me nuts. Took a bit of Googling and the results were above my head but I worked through it. Thought it might be useful for others too.

The bug is that the “sender” details are not displayed as configured in the Magento backend for the above transactional emails. Instead, the default email address for the hosting account is shown as the sender. In my case, it’s something like


Not very user friendly and potentially confusing for the customer.

This bug was introduced in the version 2.2.4 upgrade and exists in 2.2.5 as well.

The workaround is to disable the following modules (if you don’t need them of course)


by running the command

php bin/magento module:disable Amazon_Core Amazon_Login Amazon_Payment

You can read more about it at the following URL but it was pretty much over my head: https://github.com/magento/magento2/issues/14952

I hope this is of some use to those starting a 2.2.5 store.

1 Like

Thanks for sharing. It’s frustrating how many bugs got introduced to 2.2.4 and still exist in 2.2.5.

This one affects everyone and, considering order confirmation, shipment confirmation and invoice emails are the ones that are sent all the time, it’s pretty amazing that it wasn’t picked up.

Like I said, much of the discussion on the github page was over my head but I did recall from my skim reading something about how only the core code is tested and the modules such as Amazon Pay, Tomando and a couple of others that I can’t remember anymore are not core. Scary!

By default, I disable the “bloatware” that M2 comes packaged with these days. They mostly promote 3rd party services from their partners.

List of disabled modules:

*Always do your research before disabling a module