PhpMyAdmin error #1045

#1

Hi, I’ve been trying to install Magento 2.3 on my server by following all the steps in Magento 2 beginner tutorials. I’m an absolute newbie when it comes to using putty and all that stuff. I ran into a problem with a phpmyadmin when I’ve created user “magento-master” and tried logging in with it. The full error says: #1045 - Access denied for user ‘magento-master’@‘localhost’ (using password: YES). Now I’ve seek online and found some tips how to change it however all of them were kind of vauge and I couldn’t really follow. Hopefully you can help me :slight_smile:

Server has:
Ubuntu 16.04.2
MySQL 5.7.25
Php 7.2.14
Apache 2.4.18

#2

Hi @michal,

#1045 - Access denied for user ‘magento-master’@‘localhost’ (using password: YES)

This error just means the password is incorrect or you’re locked out for whatever reason. Also, sometimes you’ll get this message when your password is correct, but it’s a really bad password. Sounds odd, I know.

You should be able to solve this by logging into phpMyAdmin as the root user and resetting the password of magento-master user.

General Password Rules
Just make sure you follow these general rules:

  1. Longer than 20 characters
  2. Contains numbers
  3. Contains lower & uppercase characters
  4. Contains special characters

E.g. z65u$O2K1l&Mn7KryltF&

It’s not like you have to remember it from memory, so it may as well be super-complicated

How to Change a Users Password

1 Like
#3

Thanks, I thought it wouldn’t work since my password was really strong and I was sure I had put a correct one but it does. Probably I’ve simply copy paste a wrong thing. Thanks a lot :slight_smile:

1 Like
#4

Don’t worry. I get passwords and usernames mixed up all the time. It’s the price you pay for having so many unique passwords :slight_smile:

1 Like
#5

I know this post is a little old but wanted to mention…I also got the 1045 error and spent more time than I would like to admit trying to fix it. I didn’t have my command right in the first place. My username was incorrect so of course the password wasn’t going to work! Might want to check that right away if you’re having a problem.

1 Like