Products not showing in Categories but are there in the database and backend

My Setup:
Ubuntu 20.04.1 LTS
Apache 2.4.41
MySQL 8.0.22
PHP 7.4.3
Elasticsearch 7.6.2
Java 11.0.9
Composer 1.10.16
Magento 2.4.0

Skipped postfix part and disabled TwoFactor_Auth module

Products are synced every 6 hours from third party vendor (Inventory Source), through API, around 100000 products in total, I verified that products are loaded into database.

Shared or Dedicated Server ?
DigitalOcean droplet with 40/mo plan 80GB SSD/4vCores/8GB RAM

Did you setup the server or install Magento yourself ?
Yes to both

What I’m trying to do ?
Display products on the homepage and various categories, when i clicked categories and subcategories.

What happened ?
No products are being displayed.

On the homepage I get this:

I get products when I do search, and when I click on a particular product, it gets displayed correctly.
I merged 4 images into one, as new accounts are allowed to attach only 1 file.

I think I am missing a basic setting, please help me.
Thank you so much.

If anyone has any ideas, please let me know, as I am stuck here and can’t find any tutorials or solutions that work anywhere that I searched.

Hi @srikanth and welcome.

The behaviour you’ve described suggests one (or all) of the following:

  • The products Visibility is set to Search instead of Catalog, Searchable
  • Full Page cache needs flushing
  • Products no assigned to a category
  • Categories require reindexing

EDIT: Added additional possibilities

Hi Craig,

Firstly, let me thank you for the wonderful videos on Magento. I was able to install and get it running by watching your 46min video on Magento 2.4.0.

The only thing I did was to skip the postfix part from your video, and disabled the 2FA module.

After that, the third party integration service, handled the importing of products into database.

Now to your reply:

For all the products, it is set to ‘Catalog, Search’
Ran this in the Magento root folder:
bin/magento c:f

Still no luck.

Hmm… Try reindexing all your tables:

bin/magento indexer:reindex
bin/magento cache:clean
bin/magento cache:flush

Ran all three commands:

Ran cache:flush as well.

Still no luck.
3. Products not assigned to a category.
Kindly let me know, where I can check this.
4. Categories require reindexing.
Does that require a special command, but my guess is that indexer:reindex already does that right.

You can directly open this, and see if the fixes we are trying are working or not:

Yes, that reindex command does it all. I’ve exhausted the obvious options now. You can verify if Products are listed within the Categories by going into Catalog > Categories > (Category) > Products in category.

Out of curiosity, do Products show when you create them directly in the backend? That would rule out a Magento issue and point you in the direction of the API configuration.

Thank you for continued help.

Checked Categories > Products. Everything seems fine.

Created a new product from Admin dashboard as you suggested, but same issue.

New dummy product that i created now, is again visible through search results. Same issue.

Here is the search result page for the test product that i created:

It’s rare I offer, as I simply don’t have the time… But if you want to DM a custom login for the backend, I’ll have a poke around the settings for 5 minutes to see if anything stands out. I can’t promise I’ll find anything though.

1 Like

Pardon my ignorance, but how to send DM here.
Can I reply to the mail I got for my email id ?

Click my Profile Picture, click “Private Message”. I’ll take a look later.

Just an update:
We were able to fix the issue.

Product Attribute ‘upc’ is text field, which has Is Filterable set to yes. This is set from a third party, large number of products are synced through APIs.

We removed the ‘upc’ attribute from the Default Attribute set.

That’s it. Now the products are getting visible in their respective categories

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.