Setting up Megamenu by MGS

Hi there, I’m working on my page based on Unero template I’ve got and I run into problem when trying to create a menu.

I do have MGS Megamenu extension which documentation I find simply lacking stuff. So I can create a menu but for some reason it wont appear in the website header which is something I want. Since there also is Front End Builder by MGS I think the code of home page might be a bit messy and I can’t find any header code over there to simply put menu there.

Questions I have:

  1. Can I simply create a Megamenu and use it’s code to add to header as static block (I got “Code to add to Static blocks” which was generated to my menu)?
  2. Or maybe is it better idea to disable the plug-in and try with normal menu? Which also didn’t appear in the header by the way.

I realize you might not have come across this particular extension but maybe you’ve seen similar issue and have some ideas that might help.

Also, I’m running Magento 2.3.2.

This isn’t an extension I’m familiar with. But I have made 2 observations from your post:

  1. You’re running Magento 2.3.2. However, the extension website says it’s only compatible up to 2.2.
  2. You say the the “normal menu” doesn’t appear even before you tried the extension.

Removing variables
Ideally, when running into an issue like this you should remove as many variables as possible to narrow down your issue. Like stripping down an engine to find a faulty part. The issue clearly isn’t the extension as you said you can’t get the normal menu to work either. So, you should switch back to the Luma theme to rule out the Unero theme. To break this down:

  • Disable extension and check results to rule it out
  • Disable theme and check results to rule it out

If the normal menu still does not show, then you’ve at least ruled out those other variables and therefore made it easier to provide you with a better answer.

You should let us know what your results are and let us know if your using Sample Data or created your own Categories.

Ok, so here is how it went:

Well yes, but also in different place it says 2.3.x is supported and there was a patch couple of months ago (after 2.3.1 release for sure) so I’m positive it should work.

Hmm, what I meant is that neither regular menu nor the MGS one does’t show up where they should. The MGS one I can add to the page by adding it’s code to home page code. But then it just sits somewhere in the page and not in the header.
The regular one doesn’t show up at all but I think it used to prior to installing Unero theme.

I tried that and didn’t seem to do much.

I also did that and it also didn’t do much. Niether type of menu still didn’t show up in the header.

I am using my data and my categories so it is possible there is something wrong there however I don’t really think so as it did appear in regular menu at some point and it can show in the MGS megamenu, just not in the right place.

What I think is maybe there is somehting wrong with the header code, perhaps because of updates or simply some bugs. You can check out Unero’s documentation right here: http://themes.magesolution.com/unero/docs/m2/index.html
At the very bottom there is “For Developer” section which explaines how to create new header/footer. Unfortunately php is something I cannot understand and as you can tell their documantation is really basic.
Anyway maybe I can post some header code so you can check it out and perhaps see problem there.

I just spotted something you wrote:

It’s not possible to add something to the Header from the Body. If you put any code in the body, then the highest place you will even get that code is just under the Breadcrumbs. The same goes for the Footer.

If the Documentation is telling you to do it this way, I honestly can’t think of a reason why - Unless you legitimately wanted to add a second Menu to your pages… :man_shrugging:

Yeah, I figured that after a while. It’s just I don’t know what can cause the issue if not the header code itself since the rest seems to be working.

And no I don’t want to add second menu. Right now most of the page works as intended, all the products are in right place, the catalog works just fine. I simply cannot put the menu in the header. It’s just not there.

Anyway I will be trying to solve it and will let know if I will get new info.

Hi Michael,

  1. Homepage builder is only for homepage.
    While you insert/edit items with homepage builder, it is saved to database.
    That means if you insert mega menu with homepage builder, it only appears on homepage.

  2. MGS Megamenu (Admin Panel)

  • Create Horizontal menu here. MGS -> Megamenu -> Manage menu (exists by default)
  • Add menu items. MGS->Manage Megamenu Items.

Kind regards,

Thomas

Hi Thomas,
I am somewhat aware of how hopeage builder works at this point.
I’ve created menu this way multiple times now, and it still does not work.

Although something weird happend, after creating whole new second menu (nad having both menus active) my header and footer stopped working properly and are now kind of messed up, buttons don’t work, nothing is aligned and so on. After deleting both menus is it still broken, so there’s new problem :stuck_out_tongue:

EDIT:
Just an quick update, I’m still trying to fix the header and footer (both of wich are unsuable right now) and I installed full demo of the Unero theme with it’s database, and surprisingly it had working menu in the header BUT the header and footer were still broken.
So I’m assuming that it’s connected to some css files perhaps? But the fonts are styled for sure. I don’t really know. If you have any ideas before I do backup rollback (that purely my failure my last backup is from june, at least I didn’t do that much since then) I’d appreciate them :slight_smile:

EDIT 2:
So another update, I wanted to do backup but for some reason after importing full theme demo’s database all of my backups were gone os it wasn’t an option anymore. I reinstalled the theme and now header and footer work properly although the menu is still not. I will still be trying to find solution and let you know how am I doing.

Hi Michael,

Are you still struggling with it?

Please share your server info with me. I can help you with this issue.

Kind regards,

Thomas

Hello again,
Yes I’m still struggling with making menu to work.

I’m not sure what kind of info do need so tell me if you need any extra.
My server is running on:

Ubuntu 16.04.3 LTS
Apache 2.4.18
PHP 7.2.16

Magento is updated to 2.3.2
I have installed Unero theme by ArrowHiTech and extensions provided by them with it, most (if not all) are made by MGS, and so is the troublemaking one the Megamenu.

Sorry for double post, but my problem is solved thanks to @thomas’s help.

Apparently menu I created had parent_id “2” while my /var/www/html/app/code/MGS/Mmegamenu/Block/Mmegamenu.php
file was set to only show files with parent_id “1”.

So I went to phpmyadmin, found mgs_megamenu_parent database and simply changed the value from 2 to 1. And that fixed the issue, menu is now properly showed in the right place.
Again thank you very much Thomas :slight_smile:

1 Like

Glad it helped.

Cheers