Unable to match a Porto Demo with my setup

Correct. The documentation says only install those patches if you’re running those versions. It doesn’t say anything about installing them one-by-one. Therefore, I only uploaded the 2 files I mentioned.

Hi Craig,

Thank you. I’ll try again this evening. Maybe 7 am was too early for me I omitted something and the site breaks.

The good news is I was able to install and correctly config. ElasticSearch. It is working like a charm with Mirasvit Elasticsearch Ultimate extension (https://mirasvit.com/magento-2-extensions/elastic-search-ultimate.html). I used these guys for the first time. I normally use Amnasy but Mirasvit provides with a free module and engine installation. I installed it be my self but it is work considering that they can help for free and support their product. With Amnasty charge for these services extra $160 or something like this. I’d rather keep the money and learn something.

I hope I’ll be able to install Porto this evening and I won’t be tormenting you.


I tried exactly what you did and it gives me the same header problem and neither does the footer match. The content however is okay. You said you had to fine tune the theme to make it match the demo. What settings did you have to change to make it match? No matter what setting I change, Porto never applies the changes.

I also don’t understand the point of the Quick Start Package. I 100% agree with you that Porto needs to automate the fourth step. It would save everyone (including me) a lot of time and struggle.

@PawelP, to be fair their Documentation is written in a way that makes you second guess yourself. So, you’d be forgiven for taking a miss-step somewhere along the lines.

Great news with the ElasticSearch extension. I really like Mirasvit and Amasty for module solutions. Albeit Amasty are more expensive. Good luck with your install later.

@myrtlejeremy, I didn’t mess for too long. Once I realised what was going on and stopped digging any further. The only settings I changed were the ones I mentioned in the post. Make sure you clear these cache types after each change you make:

  • Config
  • Layouts
  • Blocks HTML
  • Full Page

Alternatively, you can simply disable those 4 whilst you’re making changes (which is what I normally do). Don’t disable the whole cache because Magento will be unbearably slow.

I’ve updated my post about the Quick Start Package.

A post was split to a new topic: Error 500 on Frontend after importing Porto Theme Demo

Hi Craig,

I put porto theme on my plate again. I need to crack it and understand what am I doing wrong.

I understand that questions about themes are not great because all theme differ and their installation process is different and all contain different modules and each of them can cause issues but hopefully someone will be able to help me.

Testing environment: 2.3.4 M fresh installation, Ubuntu 18.04, localhost with Oracle VM. All is working fine.

The installation process went fine. I uploaded the main theme files and then relevant patched in a correct order.

Source: Porto support tickets.

Activated the theme, imported static blocks and CMS pages and imported a demo.
Save the config in Porto setting panel and in Porto - Design Panel as Porto doc. instruct.

Finally, I applied the theme in M admin panel (Content/configuration/Design Configuration), cleared and flashed caches, deployed static content & removed any processed files that have already been generated.
All good so far. The site hasn’t crashed, and my frontend’s changed. I tried to change some colours, breadcrumbs, buttons using Porto - Design Pannel. Did some changes, saved, cleared/flushed cache, deploy static content, removed processed files, cleared browser cache and ZONK! :poop:

I can see that file styles-m.css holds the design data but with Porto I shouldn’t start messing with the files. All configs should come from M admin panel. I’m only guessing that my settings from the admin panel are not updating/overwriting the file. :thinking:

Is it possible that it is something to do with the directories/files permissions?
I can’t see anything in Porto docs about changing them.

Could you please give me a tip on how to fix it?
Thank you in advance.


So, what Porto does is save your Admin Settings to the Database. And then it uses these settings to generate a css sheet in the pub directory. If the changes you make are visible in the Admin, then it’s saving to the Database just fine. If those changes aren’t being reflected in the css sheet, then as you say it could be a file permission issue as Magento can’t write to the file.

Sometimes I’ve found that the changes don’t take effect either, at least until I’ve tried the following:

  • Flash Static Files Cache button in Cache Backend. Then Flush Magento Cache.
  • Clear Browser Cache

Hi Craig,
My apologies, I read your replay and wanted to say thank you.

I changed permissions to all pub/* files and directories to 777 and it worked. I can see changes in the frontend but I still don’t think RWX for all files/directories in /pub was necessary. :thinking:

I did a bit of research on permissions.
When files permissions are pretty easy to understand the directories are slightly different.

R - Read - means that the group can index the content (see what is in it) without being able to go into it,
E- Execute - group can go into the directory,
W- Write - can create/delete what is in it.

I still don understand the owner, group, a public bit.
Who is the owner, who is the group and who is the public?

I thought that magento user is the owner of all directories and files in my M root directories.
So if my pub/* directories permissions are 755 it means that the owner/magento_user can RWX
Now I would like Magento to overwrite my style.l.css file initially 644 (RW for the owner) which sits in pub/* directories. So simply thinking if magento user is the owner it can index the pub directories, and go into them, finally reaching the style-l.css file which M should be able to overwrite because it has W-write permission.

I’m probably overcomplicating all of it but I like to understand what I’m going.
When you have some time could you please shine some light on this matter?

Thank you.

I covered most of this here: How to diagnose and fix Ownerships and Permission issues. Have a watch of the video cause I animate and break it all down.

Owner: User that the Folder/File belongs to
Group: Group (of users) that you specify access to
Public: Everyone else

Example A (Private file)

You create a file my-amazon-wishlist.txt that contains your Amazon Wishlist. But you don’t want anyone else to see it, then it would look like this. Literally noone can access this file apart from the “craig” (or a superuser).

Permission  Owner  Group    File
-rwx------  craig  friends  my-amazon-wishlist.txt

(In this scenario, the friends group is irrelevant because there are no rules set)

Example B (Friends can view)

Now you decide that you want any of your friends to be able to view the list:

Permission  Owner  Group    File
-rwxr-----  craig  friends  my-amazon-wishlist.txt

(This is where the friends group comes into play)

Example C (Friends can view and edit)

Now you decide that you want any of your friends to be able to view and edit the list:

Permission  Owner  Group    File
-rwxrw----  craig  friends  my-amazon-wishlist.txt

Example D (Anyone can now view it)

So, it turns out that your friends aren’t buying you anything off your Amazon Wishlist, so you decide to let anyone be able to view it:

Permission  Owner  Group    File
-rwxrw-r--  craig  friends  my-amazon-wishlist.txt

Remember PHP

A File Structure where Owner: magento and Group: www-data is ideal. Magento is a PHP Application. Therefore, it requires PHP to be able to access specific Folder/Files. PHP belongs to the www-data Group. This is why the below command works so well when you have to reset everything:

find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + && find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + && chown -R :www-data . && chmod u+x bin/magento

Unless you’ve royally messed something up, there should never be a need to micromanage Owner/Group/Permissions of any of the folder or files.

1 Like

Hi Craig,

Thank you for this and sorry for tormeting you.
Is it possible that Porto requeres 777 permissions somethwere? Only this bl…y soft causing problems.
I mean the design doesn’t change on the frontend. I mean it does now on one of my M test installations but as I said I changed all /pub/* files/directories permissions to 777. Surely it is not correct. It works but it was a case of experiment not based on any knowladge.

No, 777 (rwxrwxrwx). This is like leaving the Windows/Doors of your home unlocked because FedEx can’t get to your postbox.

Remember, only magento or/and www-data need to make changes. If you want to allow both magento or www-data all privileges then you can adopt 775 if you really need to (rwxrwxr-e). But again, not recommended to micromanage permissions as you’re addressing the symptom and not the cause.

Hi Craig,

Thnak youi for this. I installed moe more magento and installing Porto all over again.
I need to understand what and on what stage messing thing up.

Maybe uploading Porto files via FileZila messing my files/directories permissions.
As I mentioned in one of my previous post all is good, the site is not crashing, but my saved in the M admin panel desin settings are not showing in the frontend. It is defenitely something to do with files permission. I’ll play with it this evening but if you have any tips on how to make it working pls let me know.

Thank you in advance.


It’s normally good practice to run the Owner/Group/Permission reset command whenever you upload files as tools like FileZilla just apply generic Permissions.

Download demo via ftp and then:

php bin/magento setup:upgrade
php bin/magento indexer:reindex
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento setup:static-content:deploy -f

Hi Craig,
Thank you. I’ll try.

Hi Andrey,

Thanks for the tip. I only skipped the indexer command during my installation. I don’t know if that matter but I’ll try. I defeniterly have some permissions issue but I hope I’ll finaly get there wihout exposing my site to any security issues.

A little update here. I was in the same situation that my Porto demo 28 wasn’t matching with Demo store. Spending long hours, I’ve realized that the following files caused issue as it wasn’t generating as per our demo- always the default one was generating/generated.


So I have deleted both and ran the below command, everything went smooth.

rm -rf var/view_preprocessed/* var/cache/* var/page_cache/* pub/static/*

After you apply a new template make sure you go in to the porto settings and hit save.

Then go in to porto design and hit save as well.

This will refresh the files that were listed above with the correct css. It should be as simple as that. Of course, clear all the caches on the server, varnish, etc… clear your browser cache and do a hard refresh (mac is command+shift+R).

That should take care of your problems. The header numbers don’t always match the same demo number. Same with other components. The demos may not look the exact same as what they have, but they should be somewhat close and still look like they go together. If not, then something like what I mentioned above needs done.

The patch order does not matter as they are simply replacing one or two files and none of the files are the same between all the patches.