Unable to match a Porto Demo with my setup

#1

I’m having some issues installing the Porto Theme into Magento 2.3.0. I’ve followed the documentation from the developer, but the end result is never correct. I would like to use Demo 20 for my site and have downloaded the latest version of the theme. In these files is a Quick Start Package that matches my version of Magento but I can’t seem to install it correctly either.

To install Magento, I followed the tutorial from Digital Startup in one of his latest videos that installed the latest version (which is now 2.3.1). What am I doing that is incorrect?

Click Here for Theme Documentation

0 Likes

#2

Hi @myrtlejeremy and welcome.

You’ll need to provide a few more details about your issue in order to find the best help. Such as what you mean by “I can’t seem to install it correctly”. What did you do? What did you expect to happen? What actually happened?

@Saleh_Alnaggar recently installed Porto in Magento 2.3.x. Perhaps they can weigh in on this for you…

0 Likes

#3

Hello and thank you!

Sorry that I wasn’t clear. I began installing the theme using the Documentation (as linked above). I uploaded the theme files into my server along with the patches that Porto has added for better functionality. Then I went in and applied the setup:upgrade command and imported my demo of choice. What came out was not an exact replica of the demo I wanted. The header was white and blue, not the black with white text I was expecting.

So then I tried using the Quick Start Package files which ended up taking my site down altogether. Luckily I created a snapshot in DigitalOcean so I could reset things back to the working order. I don’t have any products or customizations yet. I’m wanting to do that after I setup the theme correctly. If you’d like to see a snapshot of my results, I’ll be happy to show you. But now, I have no idea what I am supposed to do.

Since then, I’ve reinstalled Magento and created a whole new droplet in DO with Magento 2.3.1.

0 Likes

#4

So, it’s just the fact that the Demo doesn’t look like it was shown - As opposed to something being broken?

I assume you Installed Demo 20 by going into Stores > Configuration > Porto > Porto Settings > Installation?

I think the steps are:

  1. Select Demo Version: 20
  2. Overwrite Existing Blocks: Yes
  3. Overwrite Existing Pages: Yes [Then press Save Config]
  4. Import Static Blocks [Then press Save Config]
  5. Import CMS Pages [Then press Save Config]
  6. Select New Demo: 20 [Then press Save Config]

It’s been a few years since I did it.

0 Likes

#5

You are correct. I don’t believe anything is broken. I just don’t think I’m doing this right. This is how to do it according to the documentary:

Unzip Theme Package > Theme Files > Magento 2.x > Porto Theme.zip and upload all directories(There are 2 directories - app, pub) to magento 2 root directory.

Did that.

Activate SW Extensions, open command line in folder root of magento and run commands via ssh using putty or others, php bin/magento setup:upgrade .

Not sure how to activate the extensions, but I assume that they are activated once the theme is installed. I ran the setup:upgrade command as instructed.

Select Smartwave Porto theme in Stores > Configuration > General > Design > Design Theme > Design Theme for Magento 2.0.x version, and select Smartwave Porto theme in Content > Design > Configuration page for Magento 2.1.x or 2.2.x version.

Did that. Don’t see the correct results. I think part of the reason is because the documentary is too outdated to follow.

0 Likes

#6

This is the end result I need:

0 Likes

#7

This is end result I get after installation:

0 Likes

#8

Did you change your Header to Type 20?

Stores > Configuration > Porto > Porto Settings > Header > Header Type

Note: It might not be 20, you may have to cycle through them to see which one it is you’re after.

0 Likes

#9

I have in the past and the headers don’t match the demo. For my installation, it is type 13, not 20. This makes me think something isn’t right.

0 Likes

#10

They might have mis-labelled them?

0 Likes

#11

That’s what I thought too, but the text is blue instead of white and I can’t change it using their design panel. Also, the footer is incorrect and I can’t change the footer type.

0 Likes

#12

Sound like they screwed up somewhere if you ask me. What did they say?

0 Likes

#13

I can’t contact them. My support ended 6 months ago, so I’m looking around to see if others have had the same issue.

0 Likes

#14

I see. I’ll have a gander next week and see what matches what. It simply might turn out that their Demo doesn’t match any settings they provide. Purely speculation at this point.

0 Likes

#15

Okay. Can you let me know what you find?

0 Likes

#16

Yeah, I’ll update this post with my findings. Have a good weekend :+1:

0 Likes

#17

Thank you! You as well!

0 Likes

#18

Wow! I’m having the exactly same problem! I just got Porto a few days ago … I’m trying to import Demo 19 and I’m having the same issue with the website breaking and blue colour coming through - http://www.gtfostreetwear.com/

I’ve messaged support and they replied with:
"We have received your message, we will look into it and get back to you shortly with solutions. We appreciate your patience.

​or you can refer the guide below"

I followed the video attached exactly, but it still looks weird… so I’m waiting for another response

I also wanted to mention I installed Porto Quick Start Package to avoid any missing files or potential problems…

I’ll let you know what Support says or one of us find’s a solution soon


Hey Craig, my server is running on CPanel with user gtfostreetwear:gtfostreetswear group file attached

I don’t seem to have any errors with the website but I questioned if this can cause an issue anywhere or it’s the fine as the setup I’m running is on CPanel?

I looked at your Fix Ownership, Group and Permission issues - Magento 2 Tutorial

I messaged my managed VPS host and they replied "Your server is on cPanel, there’s no www-data. Apache is run with the user nobody. If you’re following instructions on some online posts, be sure to follow ones for a cPanel server.

Also we can’t provide sudo access since this is a Managed VPS"

0 Likes

#19

From what I see not only I have a problem with Porto.
I follow this topic. Guys, please add as many info as you can. I will have to revisit installing Porto some time but for now, I gave up.

Reg,
Pawel

0 Likes

#20

Hi @massamedia and welcome.

I’ll be updating this post sometime this week when I have an opportunity to install it and have a play. I look forward to seeing the reply you get from Porto Support.

So, all of my tutorials that involve a server, always assumes you’re running the same setup that I teach. Which is a Cloud/Dedicated Server environment where you have full control. This is because we can control all of the variables. When it comes to Shared Hosting, this is always the “wildcard” because the setup depends on how the Web Host wants to set things up. Plus they don’t allow full control of the server, so you will never be able to fine-tune your server or run any sudo commands.

In your situation, your Owner and Group in the screenshot would in most likeliness be correct. So, whenever you see me explain anything like magento:www-data, you would replace those instances with gtfostreetwear:gtfostreetwear. However, as you’re on a Shared Hosting plan and don’t have the permissions to change this, then your Owner & Group should never be an issue you have to worry about. The only thing you would ever have to verify is Permissions because that is something you’d still have control over. I hope that helps clear things up a little?

0 Likes