WYSIWYG displays "File validation failed" when uploading files such as PNGs

i have problem here …kindly help

What’s the file/filename you’re trying to upload and what version of Magento are you using?

thanks for your reply
png file
magento 2.3

Is it just that file or any file?

any file i try to load i get that error

when i first install magento 2.3 i was unable to upload logo and favicon so i changed fileuploader to image uploader in the vendor/magento/module-theme/view/adminhtml/ui_component/design_config_form.xml

i dont know if this could be the reason…kindly help

It’s definitely not a Permissions issue, otherwise you’d see “Destination folder is not writable or does not exists” instead of “File validation failed”.

Apparently, there was a bug that gave the same issue back in 2.2.5 and 2.2.6. But that was related to video files, not PNGs.

I’m also using the design_config_form.xml workaround but I still can’t reproduce your issue.

Bit of a longshot but do you have Do you have a PHP module installed/enabled called phpfileinfo?

Did you build this server and install Magento 2.3 yourself?

i install magento 2.3 in the softculous cpanel …

Softaculous is renowned for installing dodgy copies of Magento. I can see now why you keep running into issues. It “forces” Magento to install, but doesn’t configure the server to meet the requirements that Magento needs in order to run properly. So, everyone ends up running into issues.

For example, Softaculous does not configure your web server to install and enable all of the required PHP Modules as listed in the Official Magento Documentation. Going through this documentation should help backfill some of the issues that Softaculous has caused.

One of the missing/disabled PHP modules could be something called “fileinfo”, which is responsible for validating file types - This is causing the error you’re reporting.

i was unable to install magento for some reason …i have downloaded the file and know the process but it seems not to work for me thats why i install from softculous.

As you’re using Softaculous then it’s highly likely that you’re getting the “File validation failed” because you don’t have all of the required PHP modules installed or enabled.

Create a file called “phpinfo.php” and copy/paste the code below into it. Then upload it to your magento root directory.

<?php phpinfo(); ?>

Then open it in your browser (e.g. example.com/phpinfo.php). You should get a page like the one below that tells you what your PHP settings are for that directory.

Then scroll down the page and look for this section below. If it’s missing then that could be your problem.

FYI: If it is missing, I don’t know how to install or enable new PHP modules in cPanel because I don’t use it.

I just found a really useful section of the Official Magento Documentation. Give it a read. It even tells you every single PHP Module you need to install that Softaculous doesn’t do.

pls read it fro your end and tell me if everything is okay and what need to be fix…

https://www.themperfumes.com/phpinfo.php

There is a line in there that says --disable-fileinfo. I assume this is a configuration command that is disabling the PHP module. So I think this is one of your issues. Consult your Web Host on how to enable this on cPanel.

should i use 7.1 or 7.2 modules?

you are a saviour bro…i just solved the problem selecting 7.2 and it work …God bless your and guide u more in wisdom and understanding

1 Like