Elasticsearch systemctl start elasticsearch prosuce error message Mag 2.4 installation

Hi Craig, Thank you for your effort to produce such good informative tutorials,I’m new to ubuntu 20.04 I have just one issue regarding starting elasticsearch I keep getting this message

Job for elasticsearch.service failed because the control process exited with error code.
See “systemctl status elasticsearch.service” and “journalctl -xe” for details.

my local PC/webserver has 4GB xeon cpu 120GB SSD and of ram I have tried editing the file /etc/elasticsearch/elasticsearch.ymlnetwro changing network.host local host or 0.0.0.0 same results
even editing /etc/elasticsearch/jvm.options -Xms1g -Xmx1g values changing to 2G same thing.
firewall port 9200 is opened. what have I missed? journalctl -u elasticsearch.service produces to many Java messages

java -version result
openjdk version "1.8.0_265"
OpenJDK Runtime Environment (build 1.8.0_265-8u265-b01-0ubuntu2~20.04-b01)
OpenJDK 64-Bit Server VM (build 25.265-b01, mixed mode)

dear Craig,
After frustrating day trying to figure out what is causing this error, you installed Ubuntu 20.04 server and elasticsearch 7.6 doesn’t support it yet as per elsticsearch compatible os matrix, for me it worked on Ubuntu 20.04 after I added this line to elasticsearch.yml file
xpack.ml.enabled: false
this because it tries to load machine learning (kernel process) that is not supported with. elasticsearch 7.6. just so your viewer take notice, I’m not sure how it worked with you on DO howver on local server it didn’t run, I will try to test in cloudways as well to confirm.

Hi @steve and welcome.

I’ve not tested Elasticsearch in a local environment. I avoid local setups (unless using a VirtualBox) as it tends to introduce various unknowns.

I can’t find any mentiond of Elasticsearch being incompatible with specific OS’s such as Ubuntu 20.04. Do you have a source for this? Also, no one else has mentioned running into this problem either.

Hi Craig, thank you for your welcome and for your content,The incompatibility is mentioned in the support mattrix, here is the link : https://www.elastic.co/support/matrix I’m frustrated like you as well with the magneto Documentations.
I was successful in installing everything until the 2FA and get stuck because I didn’t get any email in my gmail to verify the barcode, I used disable command to disable the 2FA and wallahhh I accessed the admin page, however not sure enabling the 2FA again will work, this is what I’m working one right now, I use local server for testing before setting up VPS for actual clients.
another question have you tried template toaster to make themes for magento 2?

I feel like that table is simply out-of-date. It doesn’t mention 20.04 at all - As opposed to mentioning it with a :negative_squared_cross_mark: in the column.

Nope. Never had a need for something like that.