Installing a Theme Magento 2.3

Hi Craig, i followed your steps in How to install Magento 2.3 and build a web server and managed to install Magento by myself on a dedicated server in digital ocean on ubuntU 16.04 Apache and PHP 7.2.
Seems like my magento is working properly
But am currently facing the following issues:

1. Once i login to phpmyadmin i get the following warning What should i do about it is it interfering in any possible way with my theme install?:

Warning  in ./libraries/plugin_interface.lib.php#532
Parameter must be an array or an object that implements Countable

Backtrace
./libraries/display_import.lib.php#368: PMA_pluginGetOptions(
string 'Import',
array,
)
./libraries/display_import.lib.php#453: PMA_getHtmlForImportOptionsFormat(array)
./libraries/display_import.lib.php#684: PMA_getHtmlForImport(
string '5e42ddfd07daa',
string 'server',
string '',
string '',
integer 2097152,
array,
NULL,
NULL,
string '',
)
./server_import.php#31: PMA_getImportDisplay(
string 'server',
string '',
string '',
integer 2097152,
)

2. I am trying to install a theme i bought through filezzilla but i cant seem to get it done. I have the following questions:

On which folder should i place the files if i followed your exact tutorial on setting up magento is it on the www folder? the var folder the html folder? i already tried in various places but it wont seem to work!

Second should i sign in on fillezilla as the magento user or as the super user to get this done?

Do you have any instructions on how to make sure i am setting up the theme the right way?

thanks!

Hi,

Pls use your magento user, and move the theme directories and files into your magento directory root folder. If you followed Craig’s tutorial it will be in var/www/html

Themes could be a pain. Please try to refer to the theme documentation. I know that sometimes it is not easy. Docs are very often not great. Good luck.

Probably Craig will give you some more tips. A, back your data up before you’ll do anything.

Pawel

1 Like

Thanks Pawel! But should i place it straight on the var folder or go down to the html folder?

pls ref to the screenshot :slight_smile:

awesome! thanks a lot :smiley:

ur welcome :slight_smile:
i’m happy I could help

Ok Pawel so i did exactly as you said and afterwards i followed the next instructions from the theme on SSH which i guess are supposed to enable each module of the theme:

- Run command line: php bin/magento module:enable MGS_Mpanel
- Run command line: php bin/magento module:enable MGS_Mmegamenu
- Run command line: php bin/magento module:enable MGS_Portfolio
- Run command line: php bin/magento module:enable MGS_Testimonial
- Run command line: php bin/magento module:enable MGS_Brand
- Run command line: php bin/magento module:enable MGS_Promobanners
- Run command line: php bin/magento module:enable MGS_StoreLocator
- Run command line: php bin/magento module:enable MGS_Blog
- Run command line: php bin/magento module:enable MGS_QuickView
- Run command line: php bin/magento module:enable MGS_Social
- Run command line: php bin/magento module:enable MGS_Lookbook
- Run command line: php bin/magento module:enable MGS_AjaxCart
- Run command line: php bin/magento module:enable MGS_Protabs
- Run command line: php bin/magento module:enable MGS_InstantSearch
- Run command line: php bin/magento module:enable MGS_Ajaxlayernavigation
- Run command line: php bin/magento module:enable MGS_Landing (if you are using magento 2.2+)

Got for each one of them : Unknown module(s): ‘XXX’ etc etc for each one…

[email protected] : /var/www/html $ bin/magento module:enable MGS_Brand

Unknown module(s): ‘MGS_Brand’

[email protected]u-florentino : /var/www/html $ bin/magento module:enable MGS_Promobanners

Unknown module(s): ‘MGS_Promobanners’

[email protected] : /var/www/html $ bin/magento module:enable MGS_StoreLocator

Unknown module(s): ‘MGS_StoreLocator’

[email protected] : /var/www/html $ bin/magento module:enable MGS_Blog

Unknown module(s): ‘MGS_Blog’

[email protected] : /var/www/html $ bin/magento module:enable MGS_QuickView

Unknown module(s): ‘MGS_QuickView’

[email protected] : /var/www/html $ bin/magento module:enable MGS_Social

Unknown module(s): ‘MGS_Social’

[email protected] : /var/www/html $ bin/magento module:enable MGS_Lookbook

Unknown module(s): ‘MGS_Lookbook’

They also state that : - On some server, you need to set permission for var, pub or generated ( magento 2.2.2 or later ) folder, so please ask your server provider to set permission
for those folders.

Maybe that’s whats going on, how to i set this permissions?

Hi,

To set permission is very easy, however, I’m not going to advise you on how you should set your permissions.

How to set chmods/permissions:

Right click on the directory/file then click on the file/directory permissions.

From what I remember for the security reasons
files should be set 644 (owner permission -read, write; group remissions -read-only and public read-only too )
file

directories should be 755 (owner read, write, execute; group read, execute; public read, execute)

dir

However, in Magento /var directories chmod (permission) should be 777

Source:

You can try on your test environment but please wait for Craig to confirm the setting for your production.

I hope I was able to help.

I’m the one who normally asks here questions :wink:

Forgot to ask. Don’t you have to register your modules at first?

bin/magento setup:upgrade

I hope I’m not talking crap but I think at first you need to register your modules and then you can enable or disable them. I hope I’m not embarrassing myself here.

thanks Pawel let me give it a try!

Hi,

You can run this command to see a list of all modules (enabled/ disabled) installed on ur M.
bin/magento module:status

To enable/disable modules run one of these:

bin/magento module:enable moduleName
bin/magento module:disable moduleName

To uninstall this one:
bin/magento module:uninstall moduleName

1 Like

Ok so i am back haha … i did the module enable and everything went fine! I tried doing the change permissions on filezilla but they kept changing back to it’s original numeric value…

i kept getting this message when trying to activate the template:
Unable to create directory ‘/var/www/html/pub/…’. Access forbidden.

afterwards i tried changing permissions from ssh using (i first did this with magento user but said i wasnt a su then i switched to the superuser and tried again with image sudo chmod 766 -R /var/www/html

and the whole site went down and showed the message: Server unable to read htaccess file, denying access to be safe.

i am pretty sure the main problem i am facing is just the user permissions is there something i am missing or doing wrong?

Hi,
I’m affriad I won’t be able to help you.
I can easly change my permissions/chmods settings using FileZilla and they don’t overwrite.

You should be able to do it too using your magento user from FileZilla level.

I see that Craig is back so hoplefuly he will be able to give you a tip on how to deal with it.

Sorry could help.

This is a pretty standard message that you’ll see if you need to update your version of phpMyAdmin. It can be ignored or you can follow the steps I’ve covered here: How to fix PARAMETER MUST BE AN ARRAY error in phpMyAdmin

The instructions that @PawelP mentions are pretty robust and should see you through.

The simplest way to reset your Owner/Permissions/Groups is to run the following command as a superuser from within the Magento root directory:

sudo find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + && sudo find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + && sudo chown -R magento:www-data . && sudo chmod u+x bin/magento
1 Like

I am getting the same problem. I run the sudo find var generated vendor pub/static/media app/etc -type f-exec chmod ! g+w {} +sudo find var gnerate… from craig and got the follow image . First i run it in the magento root and and then in my log-in, and got the same results. What am i doing wrong. I get the file to load in FileZilla

This is what i am getting when i set the permission in FileZilla.

image

Try to log in with your superuser and run this command

sudo find var generated vendor pub/static pub/media app/etc -type f -exec chmod g+w {} + && sudo find var generated vendor pub/static pub/media app/etc -type d -exec chmod g+ws {} + && sudo chown -R magento:www-data . && sudo chmod u+x bin/magento
Then swith to your magento user and try to change your permissions using FillZilla.

I think that I stuck in exactly the same place. I’m trying to install and make my theme working.

I’ve installed it and it is working but I struggled with the file permissions. I’m sure it needs to be an easier way. I’m going to reinstall it and try to figure out what am I doing wrong.